aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDanielle Madeley <danielle.madeley@collabora.co.uk>2011-09-02 10:27:04 +0800
committerDanielle Madeley <danielle.madeley@collabora.co.uk>2011-09-02 10:27:04 +0800
commit5bc58b637fe191eabddef9517e4a810e6f667baa (patch)
tree256e74a8c20f1b5fcbbc38865aaf5c2b83467c7e /src/Makefile.am
parent078a23707194b9a1c21e42591a3a9732d46bb019 (diff)
downloadgsoc2013-empathy-5bc58b637fe191eabddef9517e4a810e6f667baa.tar
gsoc2013-empathy-5bc58b637fe191eabddef9517e4a810e6f667baa.tar.gz
gsoc2013-empathy-5bc58b637fe191eabddef9517e4a810e6f667baa.tar.bz2
gsoc2013-empathy-5bc58b637fe191eabddef9517e4a810e6f667baa.tar.lz
gsoc2013-empathy-5bc58b637fe191eabddef9517e4a810e6f667baa.tar.xz
gsoc2013-empathy-5bc58b637fe191eabddef9517e4a810e6f667baa.tar.zst
gsoc2013-empathy-5bc58b637fe191eabddef9517e4a810e6f667baa.zip
Remove control centre plugin
GNOME no longer supports control centre plugins, and it was decided at the hackfest that empathy-accounts should not appear in the control centre.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am31
1 files changed, 0 insertions, 31 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cc4eebe30..40be88c12 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -48,31 +48,6 @@ libempathy_accounts_common_la_LIBADD = \
$(LIBCHAMPLAIN_LIBS) \
$(NULL)
-if HAVE_CONTROL_CENTER_EMBEDDING
-ccmodulesdir = $(CONTROL_CENTER_EXTENSIONDIR)
-ccmodules_LTLIBRARIES = libempathy-accounts-panel.la
-
-libempathy_accounts_panel_la_SOURCES = \
- empathy-accounts-module.c \
- cc-empathy-accounts-panel.c \
- cc-empathy-accounts-panel.h \
- $(NULL)
-
-libempathy_accounts_panel_la_CPPFLAGS = \
- $(CPPFLAGS_COMMON) \
- $(CONTROL_CENTER_EMBEDDING_CFLAGS) \
- -DLOCALEDIR=\""$(datadir)/locale"\" \
- $(NULL)
-
-libempathy_accounts_panel_la_LDFLAGS = -export_dynamic -avoid-version -module -no-undefined -export-symbols-regex '^g_io_module_(load|unload)'
-
-libempathy_accounts_panel_la_LIBADD = \
- $(EMPATHY_LIBS) \
- $(CONTROL_CENTER_EMBEDDING_LIBS) \
- libempathy-accounts-common.la \
- $(NULL)
-endif
-
bin_PROGRAMS = \
empathy \
empathy-accounts \
@@ -268,12 +243,6 @@ EXTRA_DIST += \
empathy-map-view.ui
endif
-if !HAVE_CONTROL_CENTER_EMBEDDING
-EXTRA_DIST += $(libempathy_accounts_panel_la_SOURCES)
-else
-check_c_sources += $(libempathy_accounts_panel_la_SOURCES)
-endif
-
dist_man_MANS = \
empathy.1 \
empathy-accounts.1