aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEmanuele Aina <emanuele.aina@collabora.com>2013-03-28 19:32:45 +0800
committerEmanuele Aina <emanuele.aina@collabora.com>2013-04-01 18:23:44 +0800
commit15460fa9ae4e6a19e8b6e971014deb50746d90ee (patch)
tree18db9db5b9ea32420080dcc8b8332f4998f9d365 /src/Makefile.am
parent5c440c4e08f8102a9b73244697e69ad4855dbdef (diff)
downloadgsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.gz
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.bz2
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.lz
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.xz
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.zst
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.zip
Use a flat namespace for internal includes
Directly add the libempathy, libempathy-gtk and extensions directories to the include search path. This decouples header inclusions from their location and helps when reorganizing the source files layout. https://bugzilla.gnome.org/show_bug.cgi?id=696950
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b52e9ad8f..0766d9580 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,7 +3,11 @@ include $(top_srcdir)/tools/flymake.mk
CPPFLAGS_COMMON = \
$(EMPATHY_CFLAGS) \
$(ERROR_CFLAGS) \
- -I$(top_srcdir) \
+ -I$(top_srcdir)/libempathy-gtk \
+ -I$(top_srcdir)/libempathy \
+ -I$(top_srcdir)/extensions \
+ -I$(top_builddir)/libempathy-gtk \
+ -I$(top_builddir)/libempathy \
-DG_LOG_DOMAIN=\"empathy\" \
-DBIN_DIR=\"$(bindir)\" \
$(DISABLE_DEPRECATED) \