aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDebarshi Ray <debarshir@src.gnome.org>2012-07-04 21:12:15 +0800
committerDebarshi Ray <debarshir@src.gnome.org>2013-01-21 23:42:23 +0800
commit4ccbecd15680fd76ac5ebf1b8da82bffc8f68ca0 (patch)
treed8fef872aa02573e1365b3980966591277ef602c /src/Makefile.am
parentfc577ecee431fdfc91617b0cd7f6df39e575b006 (diff)
downloadgsoc2013-empathy-4ccbecd15680fd76ac5ebf1b8da82bffc8f68ca0.tar
gsoc2013-empathy-4ccbecd15680fd76ac5ebf1b8da82bffc8f68ca0.tar.gz
gsoc2013-empathy-4ccbecd15680fd76ac5ebf1b8da82bffc8f68ca0.tar.bz2
gsoc2013-empathy-4ccbecd15680fd76ac5ebf1b8da82bffc8f68ca0.tar.lz
gsoc2013-empathy-4ccbecd15680fd76ac5ebf1b8da82bffc8f68ca0.tar.xz
gsoc2013-empathy-4ccbecd15680fd76ac5ebf1b8da82bffc8f68ca0.tar.zst
gsoc2013-empathy-4ccbecd15680fd76ac5ebf1b8da82bffc8f68ca0.zip
empathy-chat: add some JavaScript to prepend messages
Fixes: https://bugzilla.gnome.org/639877
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am26
1 files changed, 25 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c2cb9f7a0..400b83b82 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -85,6 +85,11 @@ empathy_chat_SOURCES = \
empathy-chat.c \
$(NULL)
+nodist_empathy_chat_SOURCES = \
+ empathy-chat-resources.c \
+ empathy-chat-resources.h \
+ $(NULL)
+
empathy_call_SOURCES = \
empathy-call.c \
empathy-call-factory.c \
@@ -182,9 +187,28 @@ ui_DATA = \
EXTRA_DIST = \
$(autostart_DATA) \
- $(ui_DATA)
+ $(ui_DATA) \
+ empathy-chat.js \
+ empathy-chat.gresource.xml
dist_man_MANS = \
empathy.1 \
empathy-accounts.1
+BUILT_SOURCES = \
+ $(nodist_empathy_chat_SOURCES) \
+ $(NULL)
+
+CLEANFILES = $(BUILT_SOURCES)
+
+empathy-chat-resources.c: empathy-chat.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies $(srcdir)/empathy-chat.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ \
+ --sourcedir=$(srcdir) \
+ --generate-source \
+ $<
+
+empathy-chat-resources.h: empathy-chat.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies $(srcdir)/empathy-chat.gresource.xml)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ \
+ --sourcedir=$(srcdir) \
+ --generate-header \
+ $<