aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2007-05-03 22:12:30 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-05-03 22:12:30 +0800
commit214850e492efd75f8664bbfb98c6dd6bf161aeb6 (patch)
treefb788b71ca6e6b801d9cd257a6b798287735e763 /src/Makefile.am
parent563cdc5a284bc85957f60b14048ba6e42a0c7c87 (diff)
downloadgsoc2013-empathy-214850e492efd75f8664bbfb98c6dd6bf161aeb6.tar
gsoc2013-empathy-214850e492efd75f8664bbfb98c6dd6bf161aeb6.tar.gz
gsoc2013-empathy-214850e492efd75f8664bbfb98c6dd6bf161aeb6.tar.bz2
gsoc2013-empathy-214850e492efd75f8664bbfb98c6dd6bf161aeb6.tar.lz
gsoc2013-empathy-214850e492efd75f8664bbfb98c6dd6bf161aeb6.tar.xz
gsoc2013-empathy-214850e492efd75f8664bbfb98c6dd6bf161aeb6.tar.zst
gsoc2013-empathy-214850e492efd75f8664bbfb98c6dd6bf161aeb6.zip
[darcs-to-svn @ Remove EmpathySession and move all programs into src/]
svn path=/trunk/; revision=28
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am57
1 files changed, 44 insertions, 13 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b9c9ca2e8..83b071790 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,23 +1,54 @@
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -DPREFIX="\"$(prefix)"\" \
- -DSYSCONFDIR=\""$(sysconfdir)"\" \
- -DDATADIR=\""$(datadir)"\" \
- -DLIBDIR=\""$(libdir)"\" \
- $(EMPATHY_CFLAGS) \
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -DPREFIX="\"$(prefix)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ $(EMPATHY_CFLAGS) \
$(WARN_CFLAGS)
-bin_PROGRAMS = empathy
+LDADD = \
+ $(top_builddir)/libempathy/libempathy.la \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la \
+ $(EMPATHY_LIBS)
-empathy_SOURCES = \
+bin_PROGRAMS = empathy empathy-accounts empathy-chat empathy-contact-list
+empathy_SOURCES = \
empathy-main.c
-empathy_LDADD = \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la \
- $(EMPATHY_LIBS)
+empathy_accounts_SOURCES = \
+ empathy-accounts-main.c
+
+empathy_chat_SOURCES = \
+ empathy-chat-main.c
+
+empathy_contact_list_SOURCES = \
+ empathy-contact-list-main.c
+
+# Dbus service file
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.gnome.Empathy.Chat.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+# Rule to make the service file with bindir expanded
+$(service_DATA): $(service_in_files) Makefile
+ @sed -e "s|\@bindir\@|$(bindir)|" $< > $@
+
+chandlerdir = $(datadir)/telepathy/managers
+chandler_DATA = empathy-chat.chandler
autostartdir = $(datadir)/gnome/autostart
autostart_in_files = empathy.desktop.in
autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
+
+BUILT_SOURCES = \
+ org.gnome.Empathy.Chat.service
+
+EXTRA_DIST = \
+ org.gnome.Empathy.Chat.service.in \
+ $(autostart_DATA) \
+ $(chandler_DATA)
+
+CLEANFILES = $(BUILT_SOURCES)
+