aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2007-06-14 21:04:45 +0800
committerxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2007-06-14 21:04:45 +0800
commit6a18f1b044c05bc3da62cec4ab94483c01670aa2 (patch)
treea2a12eac4237cb0b5ee1d330f91a3e9458ba788e /src/Makefile.am
parent9ae74e7585a77ffcbff8d0a65b0c97922deeea7a (diff)
downloadgsoc2013-empathy-6a18f1b044c05bc3da62cec4ab94483c01670aa2.tar
gsoc2013-empathy-6a18f1b044c05bc3da62cec4ab94483c01670aa2.tar.gz
gsoc2013-empathy-6a18f1b044c05bc3da62cec4ab94483c01670aa2.tar.bz2
gsoc2013-empathy-6a18f1b044c05bc3da62cec4ab94483c01670aa2.tar.lz
gsoc2013-empathy-6a18f1b044c05bc3da62cec4ab94483c01670aa2.tar.xz
gsoc2013-empathy-6a18f1b044c05bc3da62cec4ab94483c01670aa2.tar.zst
gsoc2013-empathy-6a18f1b044c05bc3da62cec4ab94483c01670aa2.zip
2007-06-14 Xavier Claessens <xclaesse@gmail.com>
* src/org.gnome.Empathy.Chat.service.in: * src/empathy-accounts.c: * src/empathy-accounts-main.c: * src/empathy-chat-main.c: * src/empathy.c: * src/Makefile.am: * src/empathy-main.c: * libempathy/gossip-chatroom-manager.c: * autogen.sh: Empathy is no more splitted into 2 processes. It makes debugging more difficult when emmpathy-chat crashes. It's also more optimised like that since contact objects can be shared. git-svn-id: svn+ssh://svn.gnome.org/svn/empathy/trunk@154 4ee84921-47dd-4033-b63a-18d7a039a3e4
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 4 insertions, 14 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0f0c2d0c0..b89a4218d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,4 @@
-cppflags = \
+AM_CPPFLAGS = \
-I$(top_srcdir) \
-DPREFIX="\"$(prefix)"\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
@@ -8,26 +8,16 @@ cppflags = \
$(EMPATHY_CFLAGS) \
$(WARN_CFLAGS)
-libs = \
+LDADD = \
$(top_builddir)/libempathy-gtk/libempathy-gtk.la \
$(EMPATHY_LIBS)
bin_PROGRAMS = \
empathy \
- empathy-chat \
empathy-accounts
-empathy_SOURCES = empathy-main.c
-empathy_CPPFLAGS = $(cppflags)
-empathy_LDADD = $(libs)
-
-empathy_accounts_SOURCES = empathy-accounts-main.c
-empathy_accounts_CPPFLAGS = $(cppflags)
-empathy_accounts_LDADD = $(libs)
-
-empathy_chat_SOURCES = empathy-chat-main.c
-empathy_chat_CPPFLAGS = $(cppflags)
-empathy_chat_LDADD = $(libs)
+empathy_SOURCES = empathy.c
+empathy_accounts_SOURCES = empathy-accounts.c
# Dbus service file
servicedir = $(datadir)/dbus-1/services