aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-06-04 02:45:53 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-06-04 02:45:53 +0800
commitec7481901727606b0ce05f1dc2088c34f9e18b5f (patch)
tree97a0e0f147278845b1f06b26cb70d76177d05af0 /src/Makefile.am
parentf76a92f31b0d8212526fe8dd8c89dc1399812072 (diff)
downloadgsoc2013-empathy-ec7481901727606b0ce05f1dc2088c34f9e18b5f.tar
gsoc2013-empathy-ec7481901727606b0ce05f1dc2088c34f9e18b5f.tar.gz
gsoc2013-empathy-ec7481901727606b0ce05f1dc2088c34f9e18b5f.tar.bz2
gsoc2013-empathy-ec7481901727606b0ce05f1dc2088c34f9e18b5f.tar.lz
gsoc2013-empathy-ec7481901727606b0ce05f1dc2088c34f9e18b5f.tar.xz
gsoc2013-empathy-ec7481901727606b0ce05f1dc2088c34f9e18b5f.tar.zst
gsoc2013-empathy-ec7481901727606b0ce05f1dc2088c34f9e18b5f.zip
libempathy-gtk/gossip-ui-utils.c libempathy-gtk/gossip-accounts-dialog.c
2007-06-03 Xavier Claessens <xclaesse@gmail.com> * libempathy-gtk/gossip-ui-utils.c * libempathy-gtk/gossip-accounts-dialog.c * libempathy-gtk/Makefile.am * src/empathy-accounts-main.c * src/empathy-chat-main.c * src/Makefile.am * src/empathy-main.c * libempathy/gossip-utils.c * libempathy/Makefile.am * src/empathy-filter.h * src/empathy-filter-plugin.c * src/empathy-filter.xml * src/empathy-filter.c * libempathy/gossip-paths.c * libempathy/gossip-paths.h: Remove unused code. svn path=/trunk/; revision=120
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 4 insertions, 20 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 05bc6f55a..0f0c2d0c0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,7 +4,8 @@ cppflags = \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DDATADIR=\""$(datadir)"\" \
-DLIBDIR=\""$(libdir)"\" \
- $(EMPATHY_CFLAGS) \
+ -DLOCALEDIR=\""$(datadir)/locale"\" \
+ $(EMPATHY_CFLAGS) \
$(WARN_CFLAGS)
libs = \
@@ -16,9 +17,7 @@ bin_PROGRAMS = \
empathy-chat \
empathy-accounts
-empathy_SOURCES = \
- empathy-main.c \
- empathy-filter.c empathy-filter.h
+empathy_SOURCES = empathy-main.c
empathy_CPPFLAGS = $(cppflags)
empathy_LDADD = $(libs)
@@ -30,12 +29,6 @@ empathy_chat_SOURCES = empathy-chat-main.c
empathy_chat_CPPFLAGS = $(cppflags)
empathy_chat_LDADD = $(libs)
-# MC plugin
-#pluginlib_LTLIBRARIES = libempathy-filter-plugin.la
-#libempathy_filter_plugin_la_SOURCES = empathy-filter-plugin.c
-#libempathy_filter_plugin_la_CPPFLAGS = $(MISSION_CONTROL_PLUGINS_CFLAGS)
-#libempathy_filter_plugin_la_LIBADD = $(MISSION_CONTROL_PLUGINS_LIBS)
-
# Dbus service file
servicedir = $(datadir)/dbus-1/services
service_in_files = org.gnome.Empathy.Chat.service.in
@@ -48,20 +41,11 @@ $(service_DATA): $(service_in_files) Makefile
chandlerdir = $(datadir)/telepathy/managers
chandler_DATA = empathy-chat.chandler
-# Empathy filter DBus API
-empathy-filter-glue.h: empathy-filter.xml
- $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-server --output=$@ $<
-empathy-filter-gen.h: empathy-filter.xml
- $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-client --output=$@ $<
-
BUILT_SOURCES = \
- org.gnome.Empathy.Chat.service \
- empathy-filter-glue.h \
- empathy-filter-gen.h
+ org.gnome.Empathy.Chat.service
EXTRA_DIST = \
org.gnome.Empathy.Chat.service.in \
- empathy-filter.xml \
$(autostart_DATA) \
$(chandler_DATA)