aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-09-29 20:08:45 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-09-29 20:08:45 +0800
commite3e5702a683c468ccc1742515b4033f32c7d1083 (patch)
tree9036ec7c855079e59ec6b67128ee37134bb79abf /src/Makefile.am
parentf5490a416f103d552344f7df0238a39c1e76b537 (diff)
downloadgsoc2013-empathy-e3e5702a683c468ccc1742515b4033f32c7d1083.tar
gsoc2013-empathy-e3e5702a683c468ccc1742515b4033f32c7d1083.tar.gz
gsoc2013-empathy-e3e5702a683c468ccc1742515b4033f32c7d1083.tar.bz2
gsoc2013-empathy-e3e5702a683c468ccc1742515b4033f32c7d1083.tar.lz
gsoc2013-empathy-e3e5702a683c468ccc1742515b4033f32c7d1083.tar.xz
gsoc2013-empathy-e3e5702a683c468ccc1742515b4033f32c7d1083.tar.zst
gsoc2013-empathy-e3e5702a683c468ccc1742515b4033f32c7d1083.zip
Initial Voice+Video support Fixes bug #468204 (Elliot Fairweather, Xavier
2007-09-29 Xavier Claessens <xclaesse@gmail.com> * libempathy-gtk/empathy-call-window.c: * libempathy-gtk/empathy-call-window.h: * libempathy-gtk/empathy-contact-list-view.c: * libempathy-gtk/empathy-call-window.glade: * libempathy-gtk/Makefile.am: * libempathy-gtk/empathy-chat-window.c: * src/empathy-call-chandler.c: * src/empathy-call.chandler: * src/org.gnome.Empathy.Call.service.in: * src/Makefile.am: * libempathy/empathy-utils.c: * libempathy/empathy-utils.h: * libempathy/empathy-tp-call.c: * libempathy/empathy-tp-call.h: * libempathy/Makefile.am: * libempathy/tp-stream-engine.xml: * configure.ac: * doc/libempathy-gtk/libempathy-gtk-docs.sgml: * doc/libempathy/libempathy.types: * doc/libempathy/libempathy-docs.sgml: * doc/libempathy/Makefile.am: * doc/libempathy/tmpl/empathy-utils.sgml: Initial Voice+Video support Fixes bug #468204 (Elliot Fairweather, Xavier Claessens). svn path=/trunk/; revision=339
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d81601ed0..ae336df09 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,15 +15,18 @@ LDADD = \
bin_PROGRAMS = \
empathy \
- empathy-accounts
+ empathy-accounts \
+ empathy-call-chandler
empathy_SOURCES = empathy.c
empathy_accounts_SOURCES = empathy-accounts.c
+empathy_call_chandler_SOURCES = empathy-call-chandler.c
-# Dbus service file
+# Dbus service files
servicedir = $(datadir)/dbus-1/services
service_DATA = \
- org.gnome.Empathy.Chat.service
+ org.gnome.Empathy.Chat.service \
+ org.gnome.Empathy.Call.service
%.service: %.service.in Makefile
@sed -e "s|\@bindir\@|$(bindir)|" $< > $@
@@ -31,11 +34,17 @@ chandlerdir = $(datadir)/telepathy/managers
chandler_DATA = \
empathy-chat.chandler
+if HAVE_VOIP
+chandler_DATA += empathy-call.chandler
+endif
+
BUILT_SOURCES = \
- org.gnome.Empathy.Chat.service
+ org.gnome.Empathy.Chat.service \
+ org.gnome.Empathy.Call.service
EXTRA_DIST = \
org.gnome.Empathy.Chat.service.in \
+ org.gnome.Empathy.Call.service.in \
$(autostart_DATA) \
$(chandler_DATA)