aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-06-14 21:04:45 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-06-14 21:04:45 +0800
commit9dc3fd8854b3f9255ba8ab5aceca30f6d12b61e4 (patch)
treea2a12eac4237cb0b5ee1d330f91a3e9458ba788e /src/Makefile.am
parent92b095154e6c804d2d7138689629f32856eddd15 (diff)
downloadgsoc2013-empathy-9dc3fd8854b3f9255ba8ab5aceca30f6d12b61e4.tar
gsoc2013-empathy-9dc3fd8854b3f9255ba8ab5aceca30f6d12b61e4.tar.gz
gsoc2013-empathy-9dc3fd8854b3f9255ba8ab5aceca30f6d12b61e4.tar.bz2
gsoc2013-empathy-9dc3fd8854b3f9255ba8ab5aceca30f6d12b61e4.tar.lz
gsoc2013-empathy-9dc3fd8854b3f9255ba8ab5aceca30f6d12b61e4.tar.xz
gsoc2013-empathy-9dc3fd8854b3f9255ba8ab5aceca30f6d12b61e4.tar.zst
gsoc2013-empathy-9dc3fd8854b3f9255ba8ab5aceca30f6d12b61e4.zip
Empathy is no more splitted into 2 processes. It makes debugging more
2007-06-14 Xavier Claessens <xclaesse@gmail.com> * src/org.gnome.Empathy.Chat.service.in: * src/empathy-accounts.c: * src/empathy-accounts-main.c: * src/empathy-chat-main.c: * src/empathy.c: * src/Makefile.am: * src/empathy-main.c: * libempathy/gossip-chatroom-manager.c: * autogen.sh: Empathy is no more splitted into 2 processes. It makes debugging more difficult when emmpathy-chat crashes. It's also more optimised like that since contact objects can be shared. svn path=/trunk/; revision=154
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 4 insertions, 14 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0f0c2d0c0..b89a4218d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,4 @@
-cppflags = \
+AM_CPPFLAGS = \
-I$(top_srcdir) \
-DPREFIX="\"$(prefix)"\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
@@ -8,26 +8,16 @@ cppflags = \
$(EMPATHY_CFLAGS) \
$(WARN_CFLAGS)
-libs = \
+LDADD = \
$(top_builddir)/libempathy-gtk/libempathy-gtk.la \
$(EMPATHY_LIBS)
bin_PROGRAMS = \
empathy \
- empathy-chat \
empathy-accounts
-empathy_SOURCES = empathy-main.c
-empathy_CPPFLAGS = $(cppflags)
-empathy_LDADD = $(libs)
-
-empathy_accounts_SOURCES = empathy-accounts-main.c
-empathy_accounts_CPPFLAGS = $(cppflags)
-empathy_accounts_LDADD = $(libs)
-
-empathy_chat_SOURCES = empathy-chat-main.c
-empathy_chat_CPPFLAGS = $(cppflags)
-empathy_chat_LDADD = $(libs)
+empathy_SOURCES = empathy.c
+empathy_accounts_SOURCES = empathy-accounts.c
# Dbus service file
servicedir = $(datadir)/dbus-1/services