aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2007-05-06 02:25:08 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-05-06 02:25:08 +0800
commit6e3981da3b4a2126fe10a9952baf56e26970ca8d (patch)
treeb8614dec144c64feacd7ef27a674fdd113923070 /src/Makefile.am
parent214850e492efd75f8664bbfb98c6dd6bf161aeb6 (diff)
downloadgsoc2013-empathy-6e3981da3b4a2126fe10a9952baf56e26970ca8d.tar
gsoc2013-empathy-6e3981da3b4a2126fe10a9952baf56e26970ca8d.tar.gz
gsoc2013-empathy-6e3981da3b4a2126fe10a9952baf56e26970ca8d.tar.bz2
gsoc2013-empathy-6e3981da3b4a2126fe10a9952baf56e26970ca8d.tar.lz
gsoc2013-empathy-6e3981da3b4a2126fe10a9952baf56e26970ca8d.tar.xz
gsoc2013-empathy-6e3981da3b4a2126fe10a9952baf56e26970ca8d.tar.zst
gsoc2013-empathy-6e3981da3b4a2126fe10a9952baf56e26970ca8d.zip
[darcs-to-svn @ Cleanup build system and add MC plugin]
svn path=/trunk/; revision=29
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am42
1 files changed, 23 insertions, 19 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 83b071790..86ffade6b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,29 +1,33 @@
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -DPREFIX="\"$(prefix)"\" \
- -DSYSCONFDIR=\""$(sysconfdir)"\" \
- -DDATADIR=\""$(datadir)"\" \
- -DLIBDIR=\""$(libdir)"\" \
- $(EMPATHY_CFLAGS) \
- $(WARN_CFLAGS)
-
-LDADD = \
- $(top_builddir)/libempathy/libempathy.la \
+cflags = $(EMPATHY_CFLAGS) \
+ $(WARN_CFLAGS)
+
+libs = $(top_builddir)/libempathy/libempathy.la \
$(top_builddir)/libempathy-gtk/libempathy-gtk.la \
$(EMPATHY_LIBS)
bin_PROGRAMS = empathy empathy-accounts empathy-chat empathy-contact-list
-empathy_SOURCES = \
- empathy-main.c
-empathy_accounts_SOURCES = \
- empathy-accounts-main.c
+empathy_SOURCES = empathy-main.c
+empathy_CPPFLAGS = $(cflags)
+empathy_LDFLAGS = $(libs)
+
+empathy_accounts_SOURCES = empathy-accounts-main.c
+empathy_accounts_CPPFLAGS = $(cflags)
+empathy_accounts_LDFLAGS = $(libs)
+
+empathy_chat_SOURCES = empathy-chat-main.c
+empathy_chat_CPPFLAGS = $(cflags)
+empathy_chat_LDFLAGS = $(libs)
-empathy_chat_SOURCES = \
- empathy-chat-main.c
+empathy_contact_list_SOURCES = empathy-contact-list-main.c
+empathy_contact_list_CPPFLAGS = $(cflags)
+empathy_contact_list_LDFLAGS = $(libs)
-empathy_contact_list_SOURCES = \
- empathy-contact-list-main.c
+# MC plugin
+pluginlib_LTLIBRARIES = libempathy-filter-plugin.la
+libempathy_filter_plugin_la_SOURCES = empathy-filter-plugin.c
+libempathy_filter_plugin_la_CPPFLAGS = $(MISSION_CONTROL_PLUGINS_CFLAGS)
+libempathy_filter_plugin_la_LDFLAGS = $(MISSION_CONTROL_PLUGINS_LIBS)
# Dbus service file
servicedir = $(datadir)/dbus-1/services