aboutsummaryrefslogtreecommitdiffstats
path: root/nothere
diff options
context:
space:
mode:
authorJonny Lamb <jonnylamb@gnome.org>2009-10-20 20:07:52 +0800
committerJonny Lamb <jonnylamb@gnome.org>2009-10-20 20:08:55 +0800
commitda500948288ec5e9e675502151e5305bdf063592 (patch)
tree497aec6f8fa6294218a95b3f4461a5e756ae61e1 /nothere
parent90469882929d06151352d3d8e8b0e6a1f5229905 (diff)
downloadgsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar.gz
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar.bz2
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar.lz
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar.xz
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar.zst
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.zip
Remove the panel applets. (Closes bug #599042)
Signed-off-by: Jonny Lamb <jonnylamb@gnome.org>
Diffstat (limited to 'nothere')
-rw-r--r--nothere/.gitignore4
-rw-r--r--nothere/Makefile.am2
-rw-r--r--nothere/data/GNOME_NotHere_Applet.server.in.in25
-rw-r--r--nothere/data/GNOME_NotHere_Applet.xml7
-rw-r--r--nothere/data/Makefile.am36
-rw-r--r--nothere/src/Makefile.am17
-rw-r--r--nothere/src/nothere-applet.c136
-rw-r--r--nothere/src/nothere-applet.h52
8 files changed, 0 insertions, 279 deletions
diff --git a/nothere/.gitignore b/nothere/.gitignore
deleted file mode 100644
index d73fcf90c..000000000
--- a/nothere/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-GNOME_NotHere_Applet.schemas
-GNOME_NotHere_Applet.server
-GNOME_NotHere_Applet.server.in
-nothere-applet
diff --git a/nothere/Makefile.am b/nothere/Makefile.am
deleted file mode 100644
index 85d5f7528..000000000
--- a/nothere/Makefile.am
+++ /dev/null
@@ -1,2 +0,0 @@
-SUBDIRS = src data
-
diff --git a/nothere/data/GNOME_NotHere_Applet.server.in.in b/nothere/data/GNOME_NotHere_Applet.server.in.in
deleted file mode 100644
index e76ad14d2..000000000
--- a/nothere/data/GNOME_NotHere_Applet.server.in.in
+++ /dev/null
@@ -1,25 +0,0 @@
-<oaf_info>
-
-<oaf_server iid="OAFIID:GNOME_NotHere_Applet_Factory" type="exe" location="@LIBEXECDIR@/nothere-applet">
- <oaf_attribute name="repo_ids" type="stringv">
- <item value="IDL:Bonobo/GenericFactory:1.0"/>
- <item value="IDL:Bonobo/Unknown:1.0"/>
- </oaf_attribute>
- <oaf_attribute name="name" type="string" _value="Presence"/>
- <oaf_attribute name="description" type="string" _value="Set your own presence"/>
-</oaf_server>
-
-<oaf_server iid="OAFIID:GNOME_NotHere_Applet" type="factory" location="OAFIID:GNOME_NotHere_Applet_Factory">
-
- <oaf_attribute name="repo_ids" type="stringv">
- <item value="IDL:GNOME/Vertigo/PanelAppletShell:1.0"/>
- <item value="IDL:Bonobo/Control:1.0"/>
- <item value="IDL:Bonobo/Unknown:1.0"/>
- </oaf_attribute>
- <oaf_attribute name="name" type="string" _value="Presence"/>
- <oaf_attribute name="description" type="string" _value="Set your own presence"/>
- <oaf_attribute name="panel:category" type="string" value="Internet"/>
- <oaf_attribute name="panel:icon" type="string" value="empathy.png"/>
-</oaf_server>
-
-</oaf_info>
diff --git a/nothere/data/GNOME_NotHere_Applet.xml b/nothere/data/GNOME_NotHere_Applet.xml
deleted file mode 100644
index 5d425f108..000000000
--- a/nothere/data/GNOME_NotHere_Applet.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<Root>
- <popups>
- <popup name="button3">
- <menuitem name="About" verb="about" _label="_About" pixtype="stock" pixname="gtk-about"/>
- </popup>
- </popups>
-</Root>
diff --git a/nothere/data/Makefile.am b/nothere/data/Makefile.am
deleted file mode 100644
index 730406577..000000000
--- a/nothere/data/Makefile.am
+++ /dev/null
@@ -1,36 +0,0 @@
-include $(top_srcdir)/tools/shave.mk
-
-# Panel applet bonobo stuff
-serverdir = $(libdir)/bonobo/servers
-server_in_files = GNOME_NotHere_Applet.server.in
-server_DATA = $(server_in_files:.server.in=.server)
-
-
-# GConf Schemas
-#schemadir = $(GCONF_SCHEMA_FILE_DIR)
-#schema_in_files = GNOME_NotHere_Applet.schemas.in
-#schema_DATA = $(schema_in_files:.schemas.in=.schemas)
-
-# Misc data
-resourcesdir = $(pkgdatadir)
-resources_DATA = \
- GNOME_NotHere_Applet.xml
-
-notherebindir = $(libexecdir)
-
-# Build rules
-@INTLTOOL_SERVER_RULE@
-@INTLTOOL_SCHEMAS_RULE@
-
-$(server_in_files): $(server_in_files:.server.in=.server.in.in)
- $(QUIET_GEN)sed -e "s|\@LIBEXECDIR\@|$(notherebindir)|" $< > $@
-
-DISTCLEANFILES = \
- $(server_DATA) \
- $(server_in_files)
-# $(schema_DATA)
-
-EXTRA_DIST = \
- GNOME_NotHere_Applet.server.in.in \
- $(resources_DATA)
-# $(schema_in_files)
diff --git a/nothere/src/Makefile.am b/nothere/src/Makefile.am
deleted file mode 100644
index d2ff7fe4f..000000000
--- a/nothere/src/Makefile.am
+++ /dev/null
@@ -1,17 +0,0 @@
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -DPKGDATADIR=\""$(pkgdatadir)"\" \
- -DGNOMELOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
- -DIMAGEDIR=\"$(datadir)/empathy\" \
- $(NOTHERE_CFLAGS) $(WARN_CFLAGS) $(DISABLE_DEPRECATED)
-
-libexec_PROGRAMS = nothere-applet
-nothere_applet_SOURCES = \
- nothere-applet.c nothere-applet.h
-
-nothere_applet_LDFLAGS = \
- $(NOTHERE_LIBS)
-
-nothere_applet_LDADD = \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
diff --git a/nothere/src/nothere-applet.c b/nothere/src/nothere-applet.c
deleted file mode 100644
index 8cdde3e97..000000000
--- a/nothere/src/nothere-applet.c
+++ /dev/null
@@ -1,136 +0,0 @@
-/* -*- Mode: C; tab-width: 8; indent-tabs-mode: t; c-basic-offset: 8 -*- */
-/*
- * Copyright (C) 2007 Raphaël Slinckx <raphael@slinckx.net>
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
- *
- * Authors: Raphaël Slinckx <raphael@slinckx.net>
- */
-
-#include "config.h"
-
-#include <string.h>
-
-#include <glib/gi18n.h>
-#include <gtk/gtk.h>
-#include <bonobo/bonobo-ui-component.h>
-
-#include <libempathy-gtk/empathy-presence-chooser.h>
-#include <libempathy-gtk/empathy-ui-utils.h>
-
-#include "nothere-applet.h"
-
-G_DEFINE_TYPE(NotHereApplet, nothere_applet, PANEL_TYPE_APPLET)
-
-static void nothere_applet_destroy (GtkObject *object);
-static void nothere_applet_about_cb (BonoboUIComponent *uic,
- NotHereApplet *applet,
- const gchar *verb_name);
-
-static const BonoboUIVerb nothere_applet_menu_verbs [] = {
- BONOBO_UI_UNSAFE_VERB ("about", nothere_applet_about_cb),
- BONOBO_UI_VERB_END
-};
-
-static const char* authors[] = {
- "Raphaël Slinckx <raphael@slinckx.net>",
- NULL
-};
-
-static void
-nothere_applet_class_init (NotHereAppletClass *class)
-{
- GTK_OBJECT_CLASS (class)->destroy = nothere_applet_destroy;
-
- empathy_gtk_init ();
-}
-
-static gboolean
-do_not_eat_button_press (GtkWidget *widget,
- GdkEventButton *event)
-{
- if (event->button != 1) {
- g_signal_stop_emission_by_name (widget, "button_press_event");
- }
-
- return FALSE;
-}
-
-static void
-nothere_applet_init (NotHereApplet *applet)
-{
- applet->presence_chooser = empathy_presence_chooser_new ();
- g_signal_connect (G_OBJECT (applet->presence_chooser), "button_press_event",
- G_CALLBACK (do_not_eat_button_press), NULL);
-
- gtk_widget_show (applet->presence_chooser);
-
- gtk_container_add (GTK_CONTAINER (applet), applet->presence_chooser);
-
- panel_applet_set_flags (PANEL_APPLET (applet), PANEL_APPLET_EXPAND_MINOR);
- panel_applet_set_background_widget (PANEL_APPLET (applet), GTK_WIDGET (applet));
-}
-
-static void
-nothere_applet_destroy (GtkObject *object)
-{
- NotHereApplet *applet = NOTHERE_APPLET (object);
-
- applet->presence_chooser = NULL;
-
- (* GTK_OBJECT_CLASS (nothere_applet_parent_class)->destroy) (object);
-}
-
-static void
-nothere_applet_about_cb (BonoboUIComponent *uic,
- NotHereApplet *applet,
- const gchar *verb_name)
-{
- gtk_show_about_dialog (NULL,
- "name", "Presence",
- "version", PACKAGE_VERSION,
- "copyright", "Copyright \xc2\xa9 2007 Raphaël Slinckx",
- "comments", _("Set your own presence"),
- "authors", authors,
- "logo-icon-name", "stock_people",
- NULL);
-}
-
-static gboolean
-nothere_applet_factory (PanelApplet *applet,
- const gchar *iid,
- gpointer data)
-{
- if (strcmp (iid, "OAFIID:GNOME_NotHere_Applet") != 0) {
- return FALSE;
- }
-
- /* Set up the menu */
- panel_applet_setup_menu_from_file (applet,
- PKGDATADIR,
- "GNOME_NotHere_Applet.xml",
- NULL,
- nothere_applet_menu_verbs,
- applet);
-
- gtk_widget_show (GTK_WIDGET (applet));
- return TRUE;
-}
-
-PANEL_APPLET_BONOBO_FACTORY ("OAFIID:GNOME_NotHere_Applet_Factory",
- NOTHERE_TYPE_APPLET,
- "Presence", PACKAGE_VERSION,
- nothere_applet_factory,
- NULL);
diff --git a/nothere/src/nothere-applet.h b/nothere/src/nothere-applet.h
deleted file mode 100644
index 37e5d91a6..000000000
--- a/nothere/src/nothere-applet.h
+++ /dev/null
@@ -1,52 +0,0 @@
-/* -*- Mode: C; tab-width: 8; indent-tabs-mode: t; c-basic-offset: 8 -*- */
-/*
- * Copyright (C) 2007 Raphaël Slinckx <raphael@slinckx.net>
- *
- * This program is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
- *
- * Authors: Raphaël Slinckx <raphael@slinckx.net>
- */
-
-#ifndef __NOTHERE_APPLET_H__
-#define __NOTHERE_APPLET_H__
-
-#include <panel-applet.h>
-
-G_BEGIN_DECLS
-
-#define NOTHERE_TYPE_APPLET (nothere_applet_get_type ())
-#define NOTHERE_APPLET(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), NOTHERE_TYPE_APPLET, NotHereApplet))
-#define NOTHERE_APPLET_CLASS(klass) (G_TYPE_CHECK_CLASS_CAST ((klass), NOTHERE_TYPE_APPLET, NotHereAppletClass))
-#define NOTHERE_IS_APPLET(obj) (G_TYPE_CHECK_INSTANCE_TYPE ((obj), NOTHERE_TYPE_APPLET))
-#define NOTHERE_IS_APPLET_CLASS(klass) (G_TYPE_CHECK_CLASS_TYPE ((klass), NOTHERE_TYPE_APPLET))
-#define NOTHERE_APPLET_GET_CLASS(obj) (G_TYPE_INSTANCE_GET_CLASS ((obj), NOTHERE_TYPE_APPLET, NotHereAppletClass))
-
-typedef struct _NotHereApplet NotHereApplet;
-typedef struct _NotHereAppletClass NotHereAppletClass;
-
-struct _NotHereApplet {
- PanelApplet applet;
- GtkWidget *presence_chooser;
-};
-
-struct _NotHereAppletClass {
- PanelAppletClass parent_class;
-};
-
-GType nothere_applet_get_type (void);
-
-G_END_DECLS
-
-#endif /* __NOTHERE_APPLET_H__ */