aboutsummaryrefslogtreecommitdiffstats
path: root/nautilus-sendto-plugin/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2009-09-23 21:17:57 +0800
committerBastien Nocera <hadess@hadess.net>2009-09-24 22:09:42 +0800
commit0cd0ad2142e6722ffc620824e424277e1f622ce1 (patch)
tree1d40c390ba44282ab97317bb57e6ea46c43a3fb1 /nautilus-sendto-plugin/Makefile.am
parent3b1dc603c5f7174904bc1c6c01566700f0bab894 (diff)
downloadgsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar.gz
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar.bz2
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar.lz
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar.xz
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar.zst
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.zip
Add nautilus-sendto plugin
As nautilus-sendto now exports its plugin API. https://bugzilla.gnome.org/show_bug.cgi?id=596075
Diffstat (limited to 'nautilus-sendto-plugin/Makefile.am')
-rw-r--r--nautilus-sendto-plugin/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/nautilus-sendto-plugin/Makefile.am b/nautilus-sendto-plugin/Makefile.am
new file mode 100644
index 000000000..dc0c74416
--- /dev/null
+++ b/nautilus-sendto-plugin/Makefile.am
@@ -0,0 +1,19 @@
+plugindir = $(libdir)/nautilus-sendto/plugins
+
+INCLUDES = \
+ -I$(top_builddir) \
+ -DLOCALEDIR=\""$(datadir)/locale"\" \
+ $(NST_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED) \
+ $(EMPATHY_CFLAGS)
+
+plugin_LTLIBRARIES = libnstempathy.la
+
+libnstempathy_la_SOURCES = empathy-nautilus-sendto.c
+libnstempathy_la_LDFLAGS = -module -avoid-version
+libnstempathy_la_LIBADD = \
+ $(NST_LIBS) \
+ $(top_builddir)/libempathy/libempathy.la \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+