aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/empathy-time.c
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-10-13 21:00:29 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-10-13 21:00:29 +0800
commitd00adf45ea54086a8d1d29090639b5beb3f88b34 (patch)
tree9cc7756b93e51e5c9ba250e82164316e8778e3f3 /libempathy/empathy-time.c
parent0ab84cc3ffe6129ae40ad436eb62fccbd52b00ad (diff)
downloadgsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar.gz
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar.bz2
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar.lz
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar.xz
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar.zst
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.zip
Don't use deprecated GtkTooltips API. Add commented out lines in
2007-10-13 Xavier Claessens <xclaesse@gmail.com> * libempathy-gtk/empathy-chat-view.h: * libempathy-gtk/empathy-main-window.c: * libempathy-gtk/empathy-chat.c: * libempathy-gtk/empathy-chat-window.c: * libempathy-gtk/empathy-chat-view.c: * libempathy/empathy-log-manager.c: * libempathy/empathy-time.c: * libempathy/empathy-tp-chat.c: * libempathy/empathy-time.h: * libempathy/empathy-message.c: * libempathy/empathy-message.h: * libempathy/empathy-presence.c: * configure.ac: Don't use deprecated GtkTooltips API. Add commented out lines in configure.ac to disable GLib and GTK deprecated symbols. Replace EmpathyTime by time_t which is more appropriate for timestamps. * doc/*: Updated. svn path=/trunk/; revision=371
Diffstat (limited to 'libempathy/empathy-time.c')
-rw-r--r--libempathy/empathy-time.c12
1 files changed, 6 insertions, 6 deletions
diff --git a/libempathy/empathy-time.c b/libempathy/empathy-time.c
index 0851add49..9eec8adc0 100644
--- a/libempathy/empathy-time.c
+++ b/libempathy/empathy-time.c
@@ -30,7 +30,7 @@
/* Note: EmpathyTime is always in UTC. */
-EmpathyTime
+time_t
empathy_time_get_current (void)
{
return time (NULL);
@@ -63,7 +63,7 @@ empathy_time_get_local_time (struct tm *tm)
/* The format is: "20021209T23:51:30" and is in UTC. 0 is returned on
* failure. The alternative format "20021209" is also accepted.
*/
-EmpathyTime
+time_t
empathy_time_parse (const gchar *str)
{
struct tm tm;
@@ -88,8 +88,8 @@ empathy_time_parse (const gchar *str)
/* Converts the UTC timestamp to a string, also in UTC. Returns NULL on failure. */
gchar *
-empathy_time_to_string_utc (EmpathyTime t,
- const gchar *format)
+empathy_time_to_string_utc (time_t t,
+ const gchar *format)
{
gchar stamp[128];
struct tm *tm;
@@ -106,8 +106,8 @@ empathy_time_to_string_utc (EmpathyTime t,
/* Converts the UTC timestamp to a string, in local time. Returns NULL on failure. */
gchar *
-empathy_time_to_string_local (EmpathyTime t,
- const gchar *format)
+empathy_time_to_string_local (time_t t,
+ const gchar *format)
{
gchar stamp[128];
struct tm *tm;