aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2008-02-10 05:07:02 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2008-02-10 05:07:02 +0800
commitf82a1cfd7d318c35cf9fb696d38d63c9d5a899d2 (patch)
treeeee1f5cd5662a4ab6ab9a8fcbc049b6eb16dfc3e /libempathy/Makefile.am
parent8566eedace4bc9ffe440e3bd057b08a9f3810d09 (diff)
downloadgsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar.gz
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar.bz2
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar.lz
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar.xz
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar.zst
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.zip
Generate marshal.list thanks to gabble black magic.
svn path=/trunk/; revision=614
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index a114ad7c8..5d0c021b2 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -8,6 +8,7 @@ AM_CPPFLAGS = \
BUILT_SOURCES = \
empathy-marshal.h \
empathy-marshal.c \
+ empathy-marshal.list \
empathy-enum-types.h \
empathy-enum-types.c \
empathy-filter-glue.h \
@@ -84,6 +85,17 @@ libempathy_include_HEADERS = \
$(libempathy_headers) \
empathy-enum-types.h
+empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
+ ( cd $(srcdir) && \
+ sed -n -e 's/.*empathy_marshal_\([[:upper:]]*__[[:upper:]_]*\).*/\1/p' \
+ $(libempathy_la_SOURCES) ) \
+ | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
+ if cmp -s $@.tmp $@; then \
+ rm $@.tmp; \
+ else \
+ mv $@.tmp $@; \
+ fi
+
%-marshal.h: %-marshal.list Makefile
$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h