aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorSjoerd Simons <sjoerd.simons@collabora.co.uk>2009-06-30 22:57:06 +0800
committerSjoerd Simons <sjoerd.simons@collabora.co.uk>2009-07-01 01:20:49 +0800
commit941d757434d220fec709f30ac4847c7240b3d7d3 (patch)
tree7daa8df7b406bf7262ad159c91d62024411f22af /libempathy/Makefile.am
parent6a1b1c8baf4c30fabd76395e6ff81fd3b7cd621d (diff)
downloadgsoc2013-empathy-941d757434d220fec709f30ac4847c7240b3d7d3.tar
gsoc2013-empathy-941d757434d220fec709f30ac4847c7240b3d7d3.tar.gz
gsoc2013-empathy-941d757434d220fec709f30ac4847c7240b3d7d3.tar.bz2
gsoc2013-empathy-941d757434d220fec709f30ac4847c7240b3d7d3.tar.lz
gsoc2013-empathy-941d757434d220fec709f30ac4847c7240b3d7d3.tar.xz
gsoc2013-empathy-941d757434d220fec709f30ac4847c7240b3d7d3.tar.zst
gsoc2013-empathy-941d757434d220fec709f30ac4847c7240b3d7d3.zip
Optionally use libnm-glib for NetworkManager integration
Previously Empathy use the NM D-Bus interface directly. Unfortunately the d-bus calls used were deprecated and somewhat buggy (if NM wasn't running on empathy startup, it would never detect network changes). Given that NetworkManager isn't a blessed gnome dependency the code has been made optional, but it's expected that every distribution will build with NetworkManager integration anyway. Based on a patch by Tambet Ingo <tambet@novell.com>. Fixes #587446
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index 87b728464..2877dc6ae 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -10,6 +10,7 @@ AM_CPPFLAGS = \
-DG_LOG_DOMAIN=\"empathy\" \
$(LIBEMPATHY_CFLAGS) \
$(GEOCLUE_CFLAGS) \
+ $(NETWORK_MANAGER_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
@@ -65,7 +66,8 @@ nodist_libempathy_la_SOURCES =\
libempathy_la_LIBADD = \
$(top_builddir)/extensions/libemp-extensions.la \
$(LIBEMPATHY_LIBS) \
- $(GEOCLUE_LIBS)
+ $(GEOCLUE_LIBS) \
+ $(NETWORK_MANAGER_LIBS)
libempathy_la_LDFLAGS = \
-version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \