aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorJonny Lamb <jonnylamb@gnome.org>2009-10-21 02:16:58 +0800
committerJonny Lamb <jonnylamb@gnome.org>2009-10-21 02:57:14 +0800
commit8e9aa89166cf774b6d7efe83db68ac2d6540e840 (patch)
tree517ddbabbb7bbbab16648fb9ecf2efea82caeb74 /libempathy/Makefile.am
parente99bb6f9e596bbc33cefdcae5da76802424504ab (diff)
downloadgsoc2013-empathy-8e9aa89166cf774b6d7efe83db68ac2d6540e840.tar
gsoc2013-empathy-8e9aa89166cf774b6d7efe83db68ac2d6540e840.tar.gz
gsoc2013-empathy-8e9aa89166cf774b6d7efe83db68ac2d6540e840.tar.bz2
gsoc2013-empathy-8e9aa89166cf774b6d7efe83db68ac2d6540e840.tar.lz
gsoc2013-empathy-8e9aa89166cf774b6d7efe83db68ac2d6540e840.tar.xz
gsoc2013-empathy-8e9aa89166cf774b6d7efe83db68ac2d6540e840.tar.zst
gsoc2013-empathy-8e9aa89166cf774b6d7efe83db68ac2d6540e840.zip
Stop building libempathy{,-gtk} as a shared library. Closes bug #599086
Signed-off-by: Jonny Lamb <jonnylamb@gnome.org>
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am103
1 files changed, 46 insertions, 57 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index e45b16d81..1783650a9 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -22,10 +22,54 @@ BUILT_SOURCES = \
empathy-enum-types.h \
empathy-enum-types.c
-lib_LTLIBRARIES = libempathy.la
+noinst_LTLIBRARIES = libempathy.la
+
+libempathy_headers = \
+ empathy-account-settings.h \
+ empathy-account.h \
+ empathy-account-manager.h \
+ empathy-chatroom.h \
+ empathy-chatroom-manager.h \
+ empathy-call-factory.h \
+ empathy-call-handler.h \
+ empathy-connectivity.h \
+ empathy-contact.h \
+ empathy-contact-groups.h \
+ empathy-contact-list.h \
+ empathy-contact-manager.h \
+ empathy-contact-monitor.h \
+ empathy-connection-managers.h \
+ empathy-debug.h \
+ empathy-debugger.h \
+ empathy-dispatcher.h \
+ empathy-dispatch-operation.h \
+ empathy-ft-factory.h \
+ empathy-ft-handler.h \
+ empathy-handler.h \
+ empathy-idle.h \
+ empathy-irc-network.h \
+ empathy-irc-network-manager.h \
+ empathy-irc-server.h \
+ empathy-location.h \
+ empathy-log-manager.h \
+ empathy-log-store.h \
+ empathy-log-store-empathy.h \
+ empathy-message.h \
+ empathy-status-presets.h \
+ empathy-time.h \
+ empathy-tp-call.h \
+ empathy-tp-chat.h \
+ empathy-tp-contact-factory.h \
+ empathy-tp-contact-list.h \
+ empathy-tp-file.h \
+ empathy-tp-roomlist.h \
+ empathy-tube-handler.h \
+ empathy-types.h \
+ empathy-utils.h
libempathy_la_SOURCES = \
- empathy-account.c \
+ $(libempathy_headers) \
+ empathy-account.c \
empathy-account-settings.c \
empathy-account-manager.c \
empathy-chatroom.c \
@@ -76,64 +120,12 @@ libempathy_la_LIBADD = \
$(NETWORK_MANAGER_LIBS) \
$(CONNMAN_LIBS)
-libempathy_la_LDFLAGS = \
- -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \
- -export-symbols-regex ^empathy_
-
-libempathy_headers = \
- empathy-account-settings.h \
- empathy-account.h \
- empathy-account-manager.h \
- empathy-chatroom.h \
- empathy-chatroom-manager.h \
- empathy-call-factory.h \
- empathy-call-handler.h \
- empathy-connectivity.h \
- empathy-contact.h \
- empathy-contact-groups.h \
- empathy-contact-list.h \
- empathy-contact-manager.h \
- empathy-contact-monitor.h \
- empathy-connection-managers.h \
- empathy-debug.h \
- empathy-debugger.h \
- empathy-dispatcher.h \
- empathy-dispatch-operation.h \
- empathy-ft-factory.h \
- empathy-ft-handler.h \
- empathy-handler.h \
- empathy-idle.h \
- empathy-irc-network.h \
- empathy-irc-network-manager.h \
- empathy-irc-server.h \
- empathy-location.h \
- empathy-log-manager.h \
- empathy-log-store.h \
- empathy-log-store-empathy.h \
- empathy-message.h \
- empathy-status-presets.h \
- empathy-time.h \
- empathy-tp-call.h \
- empathy-tp-chat.h \
- empathy-tp-contact-factory.h \
- empathy-tp-contact-list.h \
- empathy-tp-file.h \
- empathy-tp-roomlist.h \
- empathy-tube-handler.h \
- empathy-types.h \
- empathy-utils.h
-
check_c_sources = \
$(libempathy_la_SOURCES) \
$(libempathy_headers)
include $(top_srcdir)/tools/check-coding-style.mk
check-local: check-coding-style
-libempathy_includedir = $(includedir)/libempathy/
-libempathy_include_HEADERS = \
- $(libempathy_headers) \
- empathy-enum-types.h
-
empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
$(QUIET_GEN)( cd $(srcdir) && \
sed -n -e 's/.*empathy_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
@@ -205,9 +197,6 @@ ircnetworksdir = $(datadir)/empathy
ircnetworks_DATA = \
irc-networks.xml
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libempathy.pc
-
EXTRA_DIST = \
empathy-marshal.list \
$(stylesheet_DATA) \