aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorCosimo Alfarano <cosimo.alfarano@collabora.co.uk>2010-02-24 03:32:57 +0800
committerCosimo Alfarano <cosimo.alfarano@collabora.co.uk>2010-02-26 01:26:57 +0800
commit8d4d46e440c7a6bd321fc098265db8ede27c07de (patch)
treebcdffe751459a38bd950d5424d628d831c5243a7 /libempathy/Makefile.am
parent8e24107b437f63d9b2ca93e0d5b7379ee87af98d (diff)
downloadgsoc2013-empathy-8d4d46e440c7a6bd321fc098265db8ede27c07de.tar
gsoc2013-empathy-8d4d46e440c7a6bd321fc098265db8ede27c07de.tar.gz
gsoc2013-empathy-8d4d46e440c7a6bd321fc098265db8ede27c07de.tar.bz2
gsoc2013-empathy-8d4d46e440c7a6bd321fc098265db8ede27c07de.tar.lz
gsoc2013-empathy-8d4d46e440c7a6bd321fc098265db8ede27c07de.tar.xz
gsoc2013-empathy-8d4d46e440c7a6bd321fc098265db8ede27c07de.tar.zst
gsoc2013-empathy-8d4d46e440c7a6bd321fc098265db8ede27c07de.zip
TPL Enabling patch, all-in-one.
By default TPL is disabled, use --enable-tpl configure option to enable it.
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am34
1 files changed, 25 insertions, 9 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index f6f0c0a23..1f1423952 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -8,6 +8,7 @@ AM_CPPFLAGS = \
-DDATADIR=\""$(datadir)"\" \
-DLOCALEDIR=\""$(datadir)/locale"\" \
-DG_LOG_DOMAIN=\"empathy\" \
+ $(TPL_CFLAGS) \
$(LIBEMPATHY_CFLAGS) \
$(GEOCLUE_CFLAGS) \
$(NETWORK_MANAGER_CFLAGS) \
@@ -48,9 +49,6 @@ libempathy_headers = \
empathy-irc-network.h \
empathy-irc-server.h \
empathy-location.h \
- empathy-log-manager.h \
- empathy-log-store-empathy.h \
- empathy-log-store.h \
empathy-message.h \
empathy-status-presets.h \
empathy-time.h \
@@ -63,6 +61,14 @@ libempathy_headers = \
empathy-types.h \
empathy-utils.h
+if !ENABLE_TPL
+libempathy_headers += \
+ empathy-log-manager.h \
+ empathy-log-store-empathy.h \
+ empathy-log-store.h \
+ $(NULL)
+endif
+
libempathy_la_SOURCES = \
$(libempathy_headers) \
empathy-account-settings.c \
@@ -87,9 +93,6 @@ libempathy_la_SOURCES = \
empathy-irc-network-manager.c \
empathy-irc-network.c \
empathy-irc-server.c \
- empathy-log-manager.c \
- empathy-log-store-empathy.c \
- empathy-log-store.c \
empathy-message.c \
empathy-status-presets.c \
empathy-time.c \
@@ -101,6 +104,14 @@ libempathy_la_SOURCES = \
empathy-tp-roomlist.c \
empathy-utils.c
+if !ENABLE_TPL
+libempathy_la_SOURCES += \
+ empathy-log-manager.c \
+ empathy-log-store-empathy.c \
+ empathy-log-store.c \
+ $(NULL)
+endif
+
# do not distribute generated files
nodist_libempathy_la_SOURCES =\
$(BUILT_SOURCES)
@@ -109,6 +120,7 @@ libempathy_la_LIBADD = \
$(top_builddir)/extensions/libemp-extensions.la \
$(LIBEMPATHY_LIBS) \
$(GEOCLUE_LIBS) \
+ $(TPL_LIBS) \
$(NETWORK_MANAGER_LIBS) \
$(CONNMAN_LIBS)
@@ -181,9 +193,10 @@ dtd_DATA = \
empathy-chatroom-manager.dtd \
empathy-irc-networks.dtd
+if !ENABLE_TPL
stylesheetdir = $(datadir)/empathy
-stylesheet_DATA = \
- empathy-log-manager.xsl
+stylesheet_DATA = empathy-log-manager.xsl
+endif
ircnetworksdir = $(datadir)/empathy
ircnetworks_DATA = \
@@ -191,10 +204,13 @@ ircnetworks_DATA = \
EXTRA_DIST = \
empathy-marshal.list \
- $(stylesheet_DATA) \
$(dtd_DATA) \
$(ircnetworks_DATA)
+if !ENABLE_TPL
+EXTRA_DIST += $(stylesheet_DATA)
+endif
+
CLEANFILES = \
$(BUILT_SOURCES) \
stamp-empathy-enum-types.h