aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-05-31 14:34:41 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-05-31 14:34:41 +0800
commit6fe758a0d83f6872585a177a2e821d4105642308 (patch)
tree50d79a5ae475063c38e4e62cdaaa3c3817220077 /libempathy/Makefile.am
parenta0c9dc2f22f510378063be5a8c872bfe8c92bd10 (diff)
downloadgsoc2013-empathy-6fe758a0d83f6872585a177a2e821d4105642308.tar
gsoc2013-empathy-6fe758a0d83f6872585a177a2e821d4105642308.tar.gz
gsoc2013-empathy-6fe758a0d83f6872585a177a2e821d4105642308.tar.bz2
gsoc2013-empathy-6fe758a0d83f6872585a177a2e821d4105642308.tar.lz
gsoc2013-empathy-6fe758a0d83f6872585a177a2e821d4105642308.tar.xz
gsoc2013-empathy-6fe758a0d83f6872585a177a2e821d4105642308.tar.zst
gsoc2013-empathy-6fe758a0d83f6872585a177a2e821d4105642308.zip
Fix warning when selecting all accounts.
2007-05-31 Xavier Claessens <xclaesse@gmail.com> * libempathy-gtk/gossip-account-chooser.c: Fix warning when selecting all accounts. * src/empathy-accounts-main.c: * libempathy-gtk/empathy-status-icon.c: * libempathy-gtk/gossip-accounts-dialog.h: * libempathy-gtk/gossip-accounts-dialog.c: * libempathy-gtk/gossip-preferences.h: * libempathy-gtk/gossip-preferences.c: Set parent window. * libempathy-gtk/empathy-main-window.c: Implement favorite chatroom menu and fix a leak. * libempathy-gtk/Makefile.am: * libempathy/Makefile.am: * libempathy/gossip-chatroom.c: * libempathy/gossip-chatroom.h: * libempathy/gossip-chatroom-manager.c: * libempathy/gossip-chatroom-manager.h: * libempathy/gossip-chatroom-manager.dtd: * libempathy-gtk/gossip-chatrooms-window.glade: * libempathy-gtk/gossip-chatrooms-window.c: * libempathy-gtk/gossip-chatrooms-window.h: New files to implement favorite chatrooms and a window to show them. * libempathy-gtk/gossip-chat.c: Fix tooltip leaked. * libempathy-gtk/gossip-chat-window.h: * libempathy-gtk/gossip-chat-window.c: Do not use deprecated gtk_object_sink(). Implement favorite chatroom features. Find a chat by comparing the account AND the chat ID. * src/empathy-chat-main.c: * libempathy/empathy-tp-chat.h: * libempathy/empathy-tp-chat.c: * libempathy/gossip-utils.h: * libempathy/gossip-utils.c: empathy_tp_chat_get_id() returns the Text channel's name. The chat ID is unique only for a specified account. * libempathy/empathy-tp-contact-list.c: Fix some leaks and add a FIXME comment for a leak not yet fixed. * TODO: Would be cool to have a glade catalog for libempathy-gtk. svn path=/trunk/; revision=100
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index 684d4e64b..2b1d75ecf 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -24,6 +24,8 @@ libempathy_la_SOURCES = \
gossip-debug.c gossip-debug.h \
gossip-utils.c gossip-utils.h \
gossip-message.c gossip-message.h \
+ gossip-chatroom-manager.c gossip-chatroom-manager.h \
+ gossip-chatroom.c gossip-chatroom.h \
empathy-contact-list.c empathy-contact-list.h \
empathy-contact-manager.c empathy-contact-manager.h \
empathy-tp-contact-list.c empathy-tp-contact-list.h \
@@ -49,8 +51,13 @@ libempathy_includedir = $(includedir)/empathy/
empathy-chandler-glue.h: empathy-chandler.xml
$(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_chandler --mode=glib-server --output=$@ $<
+dtddir = $(datadir)/empathy
+dtd_DATA = \
+ gossip-chatroom-manager.dtd
+
EXTRA_DIST = \
empathy-marshal.list \
- empathy-chandler.xml
+ empathy-chandler.xml \
+ $(dtd_DATA)
CLEANFILES = $(BUILT_SOURCES)