aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorEmanuele Aina <emanuele.aina@collabora.com>2013-03-28 19:32:45 +0800
committerEmanuele Aina <emanuele.aina@collabora.com>2013-04-01 18:23:44 +0800
commit15460fa9ae4e6a19e8b6e971014deb50746d90ee (patch)
tree18db9db5b9ea32420080dcc8b8332f4998f9d365 /libempathy/Makefile.am
parent5c440c4e08f8102a9b73244697e69ad4855dbdef (diff)
downloadgsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.gz
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.bz2
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.lz
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.xz
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.zst
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.zip
Use a flat namespace for internal includes
Directly add the libempathy, libempathy-gtk and extensions directories to the include search path. This decouples header inclusions from their location and helps when reorganizing the source files layout. https://bugzilla.gnome.org/show_bug.cgi?id=696950
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index 1cbd661c7..5f4059f20 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -2,8 +2,7 @@ include $(top_srcdir)/tools/flymake.mk
AM_CPPFLAGS = \
$(ERROR_CFLAGS) \
- -I. \
- -I$(top_srcdir) \
+ -I$(top_srcdir)/extensions \
-I$(top_builddir) \
-DDATADIR=\""$(datadir)"\" \
-DLOCALEDIR=\""$(datadir)/locale"\" \
@@ -199,7 +198,7 @@ stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
--fhead "G_BEGIN_DECLS\n\n" \
--ftail "G_END_DECLS\n\n" \
--ftail "#endif /* __LIBEMPATHY_ENUM_TYPES_H__ */\n" \
- --fprod '#include "libempathy/@filename@"\n' \
+ --fprod '#include "@filename@"\n' \
--eprod "#define EMPATHY_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n" \
--eprod "GType @enum_name@_get_type (void);\n" \
$(libempathy_headers) ) > xgen-gth \