aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorEmanuele Aina <emanuele.aina@collabora.com>2013-03-26 20:09:29 +0800
committerEmanuele Aina <emanuele.aina@collabora.com>2013-04-01 17:50:29 +0800
commit3992967e7a3015a48b5db9c7e652105abe38856e (patch)
treedf9901dc03195bfbfd7fa3bab97fb9c0f7e5b557 /libempathy/Makefile.am
parent4299f29ac941292054b4e004aac51e1b143a386a (diff)
downloadgsoc2013-empathy-3992967e7a3015a48b5db9c7e652105abe38856e.tar
gsoc2013-empathy-3992967e7a3015a48b5db9c7e652105abe38856e.tar.gz
gsoc2013-empathy-3992967e7a3015a48b5db9c7e652105abe38856e.tar.bz2
gsoc2013-empathy-3992967e7a3015a48b5db9c7e652105abe38856e.tar.lz
gsoc2013-empathy-3992967e7a3015a48b5db9c7e652105abe38856e.tar.xz
gsoc2013-empathy-3992967e7a3015a48b5db9c7e652105abe38856e.tar.zst
gsoc2013-empathy-3992967e7a3015a48b5db9c7e652105abe38856e.zip
Embed DTDs for XML validation as GResources
https://bugzilla.gnome.org/show_bug.cgi?id=696974
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am18
1 files changed, 14 insertions, 4 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index 36de4d6c2..77484d2f1 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -21,6 +21,8 @@ AM_CPPFLAGS = \
$(DISABLE_DEPRECATED)
BUILT_SOURCES = \
+ empathy-dtd-resources.c \
+ empathy-dtd-resources.h \
empathy-enum-types.h \
empathy-enum-types.c
@@ -134,8 +136,7 @@ libempathy_la_LIBADD = \
$(UOA_LIBS) \
$(LIBM)
-dtddir = $(datadir)/empathy
-dtd_DATA = \
+dtd_resources_files = \
empathy-status-presets.dtd \
empathy-contact-groups.dtd \
empathy-chatroom-manager.dtd \
@@ -145,8 +146,17 @@ ircnetworksdir = $(datadir)/empathy
ircnetworks_DATA = \
irc-networks.xml
-EXTRA_DIST = \
- $(dtd_DATA) \
+dtd_resource_files: $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/empathy-dtd.gresource.xml)
+
+empathy-dtd-resources.c: empathy-dtd.gresource.xml $(dtd_resource_files)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
+
+empathy-dtd-resources.h: empathy-dtd.gresource.xml $(dtd_resource_files)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
+
+EXTRA_DIST = \
+ empathy-dtd.gresource.xml \
+ $(dtd_resources_files) \
$(ircnetworks_DATA)
CLEANFILES = \