aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2011-08-18 17:31:10 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2011-08-18 18:15:06 +0800
commit9ddd25f8589ae0cd5ec8e09c4c012e4ccac6a416 (patch)
tree4e4cfd5b8f801acff74edfdd5072f45d7038e00b /libempathy/Makefile.am
parent7fbf3e0c200b0a3c5086fdce0cc19afe48c429bb (diff)
downloadgsoc2013-empathy-9ddd25f8589ae0cd5ec8e09c4c012e4ccac6a416.tar
gsoc2013-empathy-9ddd25f8589ae0cd5ec8e09c4c012e4ccac6a416.tar.gz
gsoc2013-empathy-9ddd25f8589ae0cd5ec8e09c4c012e4ccac6a416.tar.bz2
gsoc2013-empathy-9ddd25f8589ae0cd5ec8e09c4c012e4ccac6a416.tar.lz
gsoc2013-empathy-9ddd25f8589ae0cd5ec8e09c4c012e4ccac6a416.tar.xz
gsoc2013-empathy-9ddd25f8589ae0cd5ec8e09c4c012e4ccac6a416.tar.zst
gsoc2013-empathy-9ddd25f8589ae0cd5ec8e09c4c012e4ccac6a416.zip
Port to new tp-glib client factory
- EmpathyChannelFactory has been changed to EmpathyClientFactory and inherit from TpAutomaticClientFactory. - We now always use the _with_am variant of TpSimple* constructors - We define our own factory as default. - Replace empathy_get_account_for_connection() by tp_connection_get_account() - The factory is passed to EmpathyTpChat and TpyCallChannel - Use tp_simple_client_factory_ensure_account() instead of tp_account_manager_ensure_account(). - Rely on the factory to prepare connection features. This should ensure that all the TpProxy and TpContact objects created in Empathy are shared and use EmpathyClientFactory. https://bugzilla.gnome.org/show_bug.cgi?id=655799
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index f701f7480..34a706113 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -33,9 +33,9 @@ libempathy_headers = \
empathy-account-settings.h \
empathy-auth-factory.h \
empathy-camera-monitor.h \
- empathy-channel-factory.h \
empathy-chatroom-manager.h \
empathy-chatroom.h \
+ empathy-client-factory.h \
empathy-connection-managers.h \
empathy-connectivity.h \
empathy-contact-groups.h \
@@ -76,9 +76,9 @@ libempathy_handwritten_source = \
empathy-account-settings.c \
empathy-auth-factory.c \
empathy-camera-monitor.c \
- empathy-channel-factory.c \
empathy-chatroom-manager.c \
empathy-chatroom.c \
+ empathy-client-factory.c \
empathy-connection-managers.c \
empathy-connectivity.c \
empathy-contact-groups.c \