aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorDanielle Madeley <danielle.madeley@collabora.co.uk>2011-11-07 09:03:50 +0800
committerDanielle Madeley <danielle.madeley@collabora.co.uk>2011-11-07 09:03:50 +0800
commit7c0dff773920a0796e079d5c79165a12fc7e8ddd (patch)
tree61c3c535adb7b034373cc3f7af53909d6e396044 /libempathy/Makefile.am
parentd12639558defd8be43dc0c5c43a80f6397900bd5 (diff)
downloadgsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar.gz
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar.bz2
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar.lz
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar.xz
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.tar.zst
gsoc2013-empathy-7c0dff773920a0796e079d5c79165a12fc7e8ddd.zip
Make GOA optional again
There is an --disable-goa flag in Empathy's configure, which should be able to disable GOA, except it had been included as a required dependency. This patch makes it completely optional again. Fixes: https://bugzilla.gnome.org/show_bug.cgi?id=663442
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am59
1 files changed, 37 insertions, 22 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index 0662f2cf0..1f4bdbcb9 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -16,6 +16,7 @@ AM_CPPFLAGS = \
$(NETWORK_MANAGER_CFLAGS) \
$(CONNMAN_CFLAGS) \
$(UDEV_CFLAGS) \
+ $(GOA_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
@@ -29,7 +30,6 @@ libempathy_headers = \
action-chain-internal.h \
empathy-account-settings.h \
empathy-auth-factory.h \
- empathy-goa-auth-handler.h \
empathy-camera-monitor.h \
empathy-chatroom-manager.h \
empathy-chatroom.h \
@@ -73,7 +73,6 @@ libempathy_handwritten_source = \
action-chain.c \
empathy-account-settings.c \
empathy-auth-factory.c \
- empathy-goa-auth-handler.c \
empathy-camera-monitor.c \
empathy-chatroom-manager.c \
empathy-chatroom.c \
@@ -109,10 +108,41 @@ libempathy_handwritten_source = \
empathy-tp-streamed-media.c \
empathy-utils.c
+# these are sources that depend on GOA
+goa_sources = \
+ empathy-goa-auth-handler.c \
+ empathy-goa-auth-handler.h \
+ $(NULL)
+
libempathy_la_SOURCES = \
$(libempathy_handwritten_source) \
cheese-camera-device-monitor.c cheese-camera-device-monitor.h
+dtddir = $(datadir)/empathy
+dtd_DATA = \
+ empathy-status-presets.dtd \
+ empathy-contact-groups.dtd \
+ empathy-chatroom-manager.dtd \
+ empathy-irc-networks.dtd
+
+ircnetworksdir = $(datadir)/empathy
+ircnetworks_DATA = \
+ irc-networks.xml
+
+EXTRA_DIST = \
+ $(dtd_DATA) \
+ $(ircnetworks_DATA)
+
+CLEANFILES = \
+ $(BUILT_SOURCES) \
+ stamp-empathy-enum-types.h
+
+if HAVE_GOA
+libempathy_la_SOURCES += $(goa_sources)
+else
+EXTRA_DIST += $(goa_sources)
+endif
+
# do not distribute generated files
nodist_libempathy_la_SOURCES =\
$(BUILT_SOURCES)
@@ -127,10 +157,14 @@ libempathy_la_LIBADD = \
$(NETWORK_MANAGER_LIBS) \
$(CONNMAN_LIBS) \
$(UDEV_LIBS) \
+ $(GOA_LIBS) \
$(LIBM)
check_c_sources = \
- $(libempathy_handwritten_source)
+ $(libempathy_handwritten_source) \
+ $(goa_sources) \
+ $(NULL)
+
include $(top_srcdir)/tools/check-coding-style.mk
check-local: check-coding-style
@@ -171,22 +205,3 @@ empathy-enum-types.c: $(libempathy_headers) Makefile
$(libempathy_headers) ) > xgen-gtc \
&& cp xgen-gtc $(@F) \
&& rm -f xgen-gtc
-
-dtddir = $(datadir)/empathy
-dtd_DATA = \
- empathy-status-presets.dtd \
- empathy-contact-groups.dtd \
- empathy-chatroom-manager.dtd \
- empathy-irc-networks.dtd
-
-ircnetworksdir = $(datadir)/empathy
-ircnetworks_DATA = \
- irc-networks.xml
-
-EXTRA_DIST = \
- $(dtd_DATA) \
- $(ircnetworks_DATA)
-
-CLEANFILES = \
- $(BUILT_SOURCES) \
- stamp-empathy-enum-types.h