aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-06-23 01:46:51 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-06-23 01:46:51 +0800
commit7571ad9cda32496107a7067fc0416aa1e4466cce (patch)
tree90304855706f32eaddfd4a526ff859175f3ebe31 /libempathy/Makefile.am
parent84f53258270412f78f6d0f6367ea00d9953fa24a (diff)
downloadgsoc2013-empathy-7571ad9cda32496107a7067fc0416aa1e4466cce.tar
gsoc2013-empathy-7571ad9cda32496107a7067fc0416aa1e4466cce.tar.gz
gsoc2013-empathy-7571ad9cda32496107a7067fc0416aa1e4466cce.tar.bz2
gsoc2013-empathy-7571ad9cda32496107a7067fc0416aa1e4466cce.tar.lz
gsoc2013-empathy-7571ad9cda32496107a7067fc0416aa1e4466cce.tar.xz
gsoc2013-empathy-7571ad9cda32496107a7067fc0416aa1e4466cce.tar.zst
gsoc2013-empathy-7571ad9cda32496107a7067fc0416aa1e4466cce.zip
Install libempathy and libempathy-gtk and make their API public.
2007-06-22 Xavier Claessens <xclaesse@gmail.com> * libempathy-gtk/libempathy-gtk.pc.in: * libempathy-gtk/Makefile.am: * libempathy/libempathy.pc.in: * libempathy/Makefile.am: * configure.ac: Install libempathy and libempathy-gtk and make their API public. svn path=/trunk/; revision=172
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am67
1 files changed, 45 insertions, 22 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index 00ce4233a..c30f62fa5 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -10,34 +10,54 @@ BUILT_SOURCES = \
empathy-marshal.c \
empathy-chandler-glue.h
-noinst_LTLIBRARIES = libempathy.la
+lib_LTLIBRARIES = libempathy.la
-libempathy_la_SOURCES = \
- empathy-conf.c empathy-conf.h \
- empathy-contact.c empathy-contact.h \
- empathy-avatar.c empathy-avatar.h \
- empathy-time.c empathy-time.h \
- empathy-presence.c empathy-presence.h \
- empathy-debug.c empathy-debug.h \
- empathy-utils.c empathy-utils.h \
- empathy-message.c empathy-message.h \
- empathy-chatroom-manager.c empathy-chatroom-manager.h \
- empathy-chatroom.c empathy-chatroom.h \
- empathy-contact-list.c empathy-contact-list.h \
- empathy-contact-manager.c empathy-contact-manager.h \
- empathy-tp-group.c empathy-tp-group.h \
- empathy-tp-contact-list.c empathy-tp-contact-list.h \
- empathy-tp-chat.c empathy-tp-chat.h \
- empathy-tp-chatroom.c empathy-tp-chatroom.h \
- empathy-chandler.c empathy-chandler.h \
- empathy-idle.c empathy-idle.h \
- empathy-log-manager.c empathy-log-manager.h \
+libempathy_la_SOURCES = \
+ empathy-conf.c \
+ empathy-contact.c \
+ empathy-avatar.c \
+ empathy-time.c \
+ empathy-presence.c \
+ empathy-debug.c \
+ empathy-utils.c \
+ empathy-message.c \
+ empathy-chatroom-manager.c \
+ empathy-chatroom.c \
+ empathy-contact-list.c \
+ empathy-contact-manager.c \
+ empathy-tp-group.c \
+ empathy-tp-contact-list.c \
+ empathy-tp-chat.c \
+ empathy-tp-chatroom.c \
+ empathy-chandler.c \
+ empathy-idle.c \
+ empathy-log-manager.c \
empathy-marshal-main.c
libempathy_la_LIBADD = \
$(LIBEMPATHY_LIBS)
-libempathy_includedir = $(includedir)/empathy/
+libempathydir = $(includedir)/libempathy/
+libempathy_HEADERS = \
+ empathy-conf.h \
+ empathy-contact.h \
+ empathy-avatar.h \
+ empathy-time.h \
+ empathy-presence.h \
+ empathy-debug.h \
+ empathy-utils.h \
+ empathy-message.h \
+ empathy-chatroom-manager.h \
+ empathy-chatroom.h \
+ empathy-contact-list.h \
+ empathy-contact-manager.h \
+ empathy-tp-group.h \
+ empathy-tp-contact-list.h \
+ empathy-tp-chat.h \
+ empathy-tp-chatroom.h \
+ empathy-chandler.h \
+ empathy-idle.h \
+ empathy-log-manager.h
%-marshal.h: %-marshal.list Makefile.am
$(GLIB_GENMARSHAL) --header --prefix=$(subst -,_,$*)_marshal $< > $*-marshal.h
@@ -58,6 +78,9 @@ stylesheetdir = $(datadir)/empathy
stylesheet_DATA = \
empathy-log-manager.xsl
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libempathy.pc
+
EXTRA_DIST = \
empathy-marshal.list \
empathy-chandler.xml \