aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2007-04-26 05:59:20 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-04-26 05:59:20 +0800
commit40c0d1ba5434b5c5d4f8b7ff6fedd1add5c03ce6 (patch)
treec1426dc8388fc711bf4a5e8de42fd3a4b76e6842 /libempathy/Makefile.am
downloadgsoc2013-empathy-40c0d1ba5434b5c5d4f8b7ff6fedd1add5c03ce6.tar
gsoc2013-empathy-40c0d1ba5434b5c5d4f8b7ff6fedd1add5c03ce6.tar.gz
gsoc2013-empathy-40c0d1ba5434b5c5d4f8b7ff6fedd1add5c03ce6.tar.bz2
gsoc2013-empathy-40c0d1ba5434b5c5d4f8b7ff6fedd1add5c03ce6.tar.lz
gsoc2013-empathy-40c0d1ba5434b5c5d4f8b7ff6fedd1add5c03ce6.tar.xz
gsoc2013-empathy-40c0d1ba5434b5c5d4f8b7ff6fedd1add5c03ce6.tar.zst
gsoc2013-empathy-40c0d1ba5434b5c5d4f8b7ff6fedd1add5c03ce6.zip
[darcs-to-svn @ initial import]
svn path=/trunk/; revision=2
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am54
1 files changed, 54 insertions, 0 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
new file mode 100644
index 000000000..30d40c595
--- /dev/null
+++ b/libempathy/Makefile.am
@@ -0,0 +1,54 @@
+AM_CPPFLAGS = \
+ -I. \
+ -I$(top_srcdir) \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLOCALEDIR=\""$(datadir)/locale"\" \
+ $(EMPATHY_CFLAGS) \
+ $(WARN_CFLAGS)
+
+BUILT_SOURCES = \
+ empathy-marshal.h \
+ empathy-marshal.c \
+ empathy-chandler-glue.h
+
+noinst_LTLIBRARIES = libempathy.la
+
+libempathy_la_SOURCES = \
+ gossip-conf.c gossip-conf.h \
+ gossip-contact.c gossip-contact.h \
+ gossip-avatar.c gossip-avatar.h \
+ gossip-time.c gossip-time.h \
+ gossip-presence.c gossip-presence.h \
+ gossip-telepathy-group.c gossip-telepathy-group.h \
+ gossip-paths.c gossip-paths.h \
+ gossip-debug.c gossip-debug.h \
+ gossip-utils.c gossip-utils.h \
+ gossip-message.c gossip-message.h \
+ empathy-session.c empathy-session.h \
+ empathy-contact-list.c empathy-contact-list.h \
+ empathy-contact-manager.c empathy-contact-manager.h \
+ empathy-tp-chat.c empathy-tp-chat.h \
+ empathy-chandler.c empathy-chandler.h \
+ empathy-marshal-main.c
+
+libempathy_la_LIBADD = \
+ $(EMPATHY_LIBS)
+
+libempathy_includedir = $(includedir)/empathy/
+
+%-marshal.h: %-marshal.list Makefile.am
+ $(GLIB_GENMARSHAL) --header --prefix=$(subst -,_,$*)_marshal $< > $*-marshal.h
+
+%-marshal.c: %-marshal.list Makefile.am
+ $(GLIB_GENMARSHAL) --body --prefix=$(subst -,_,$*)_marshal $< > $*-marshal.c
+
+%-marshal-main.c: %-marshal.c %-marshal.h
+
+empathy-chandler-glue.h: empathy-chandler.xml
+ $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_chandler --mode=glib-server --output=$@ $<
+
+EXTRA_DIST = \
+ empathy-marshal.list \
+ empathy-chandler.xml
+
+CLEANFILES = $(BUILT_SOURCES)