aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorJonny Lamb <jonny.lamb@collabora.co.uk>2009-08-19 20:31:21 +0800
committerJonny Lamb <jonny.lamb@collabora.co.uk>2009-08-20 00:17:03 +0800
commit094a490dac0da29d685e5f1cbb06bc6caa588d3a (patch)
tree017139cbd2d0d7fc05e43b75307f3cb7975323ad /libempathy/Makefile.am
parent4b87ece33144d35023b713d8e7d1be9262bc272a (diff)
downloadgsoc2013-empathy-094a490dac0da29d685e5f1cbb06bc6caa588d3a.tar
gsoc2013-empathy-094a490dac0da29d685e5f1cbb06bc6caa588d3a.tar.gz
gsoc2013-empathy-094a490dac0da29d685e5f1cbb06bc6caa588d3a.tar.bz2
gsoc2013-empathy-094a490dac0da29d685e5f1cbb06bc6caa588d3a.tar.lz
gsoc2013-empathy-094a490dac0da29d685e5f1cbb06bc6caa588d3a.tar.xz
gsoc2013-empathy-094a490dac0da29d685e5f1cbb06bc6caa588d3a.tar.zst
gsoc2013-empathy-094a490dac0da29d685e5f1cbb06bc6caa588d3a.zip
configure: enable connectivity building with nm, connman, auto or none
Signed-off-by: Jonny Lamb <jonny.lamb@collabora.co.uk>
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index 7600ee5d4..0250a63d8 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -10,7 +10,8 @@ AM_CPPFLAGS = \
-DG_LOG_DOMAIN=\"empathy\" \
$(LIBEMPATHY_CFLAGS) \
$(GEOCLUE_CFLAGS) \
- $(NETWORK_MANAGER_CFLAGS) \
+ $(NETWORK_MANAGER_CFLAGS) \
+ $(CONNMAN_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
@@ -70,7 +71,8 @@ libempathy_la_LIBADD = \
$(top_builddir)/extensions/libemp-extensions.la \
$(LIBEMPATHY_LIBS) \
$(GEOCLUE_LIBS) \
- $(NETWORK_MANAGER_LIBS)
+ $(NETWORK_MANAGER_LIBS) \
+ $(CONNMAN_LIBS)
libempathy_la_LDFLAGS = \
-version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \