aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-06-09 17:28:44 +0800
committerEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-06-09 17:28:44 +0800
commit8944f13286ba5293781f2d57980da284cb2aa29d (patch)
tree91aa682420a072399f03ac7fb456f62c13064add /libempathy/Makefile.am
parent981a1377f660a9d1e3660dc66613b993b78486fc (diff)
parent3f52e59aa058c16a9ba115398681a16b1e289cd1 (diff)
downloadgsoc2013-empathy-8944f13286ba5293781f2d57980da284cb2aa29d.tar
gsoc2013-empathy-8944f13286ba5293781f2d57980da284cb2aa29d.tar.gz
gsoc2013-empathy-8944f13286ba5293781f2d57980da284cb2aa29d.tar.bz2
gsoc2013-empathy-8944f13286ba5293781f2d57980da284cb2aa29d.tar.lz
gsoc2013-empathy-8944f13286ba5293781f2d57980da284cb2aa29d.tar.xz
gsoc2013-empathy-8944f13286ba5293781f2d57980da284cb2aa29d.tar.zst
gsoc2013-empathy-8944f13286ba5293781f2d57980da284cb2aa29d.zip
Merge branch 'call'
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index 41cec88fd..48846311f 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -10,6 +10,7 @@ AM_CPPFLAGS = \
-DG_LOG_DOMAIN=\"empathy\" \
-DGCR_API_SUBJECT_TO_CHANGE \
$(EMPATHY_CFLAGS) \
+ $(YELL_CFLAGS) \
$(GEOCLUE_CFLAGS) \
$(GEOCODE_CFLAGS) \
$(NETWORK_MANAGER_CFLAGS) \
@@ -110,6 +111,7 @@ nodist_libempathy_la_SOURCES =\
libempathy_la_LIBADD = \
$(top_builddir)/extensions/libemp-extensions.la \
+ $(top_builddir)/telepathy-yell/telepathy-yell/libtelepathy-yell.la \
$(GCR_LIBS) \
$(EMPATHY_LIBS) \
$(GEOCLUE_LIBS) \
@@ -134,12 +136,12 @@ empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
mv $@.tmp $@; \
fi
-%-marshal.h: %-marshal.list Makefile
- $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+empathy-marshal.h: empathy-marshal.list Makefile
+ $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_empathy_marshal $< > empathy-marshal.h
-%-marshal.c: %-marshal.list Makefile
+empathy-marshal.c: empathy-marshal.list Makefile
$(AM_V_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
- $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
+ $(GLIB_GENMARSHAL) --body --prefix=_empathy_marshal $< >> empathy-marshal.c
empathy-enum-types.h: stamp-empathy-enum-types.h
$(AM_V_GEN)true