aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2008-02-10 05:06:58 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2008-02-10 05:06:58 +0800
commit8566eedace4bc9ffe440e3bd057b08a9f3810d09 (patch)
treeae2f0fe08a3d5cd2eaf28def4106a4bfa422da7e /libempathy/Makefile.am
parentb14a2d1a15a4fa17acd02afb6958ff57a8e0c6d6 (diff)
downloadgsoc2013-empathy-8566eedace4bc9ffe440e3bd057b08a9f3810d09.tar
gsoc2013-empathy-8566eedace4bc9ffe440e3bd057b08a9f3810d09.tar.gz
gsoc2013-empathy-8566eedace4bc9ffe440e3bd057b08a9f3810d09.tar.bz2
gsoc2013-empathy-8566eedace4bc9ffe440e3bd057b08a9f3810d09.tar.lz
gsoc2013-empathy-8566eedace4bc9ffe440e3bd057b08a9f3810d09.tar.xz
gsoc2013-empathy-8566eedace4bc9ffe440e3bd057b08a9f3810d09.tar.zst
gsoc2013-empathy-8566eedace4bc9ffe440e3bd057b08a9f3810d09.zip
Do not export symbols outside the empathy_ namespace.
svn path=/trunk/; revision=613
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index 3c87db37c..a114ad7c8 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -11,7 +11,8 @@ BUILT_SOURCES = \
empathy-enum-types.h \
empathy-enum-types.c \
empathy-filter-glue.h \
- empathy-chandler-glue.h
+ empathy-chandler-glue.h \
+ tp-stream-engine-gen.h
lib_LTLIBRARIES = libempathy.la
@@ -49,7 +50,8 @@ libempathy_la_LIBADD = \
$(LIBEMPATHY_LIBS)
libempathy_la_LDFLAGS = \
- -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE}
+ -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \
+ -export-symbols-regex ^empathy_
libempathy_headers = \
empathy-avatar.h \
@@ -75,8 +77,7 @@ libempathy_headers = \
empathy-chandler.h \
empathy-filter.h \
empathy-idle.h \
- empathy-log-manager.h \
- tp-stream-engine-gen.h
+ empathy-log-manager.h
libempathy_includedir = $(includedir)/libempathy/
libempathy_include_HEADERS = \
@@ -84,11 +85,11 @@ libempathy_include_HEADERS = \
empathy-enum-types.h
%-marshal.h: %-marshal.list Makefile
- $(GLIB_GENMARSHAL) --header --prefix=$(subst -,_,$*)_marshal $< > $*-marshal.h
+ $(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
%-marshal.c: %-marshal.list Makefile
echo "#include \"empathy-marshal.h\"" > $@ && \
- $(GLIB_GENMARSHAL) --body --prefix=$(subst -,_,$*)_marshal $< >> $*-marshal.c
+ $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
empathy-chandler-glue.h: empathy-chandler.xml Makefile
$(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_chandler --mode=glib-server --output=$@ $<