aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-02-23 01:15:11 +0800
committerSjoerd Simons <sjoerd.simons@collabora.co.uk>2011-02-24 01:12:56 +0800
commit10edf350020350475ece049d9c8fd969f70cf5c5 (patch)
treeecca3e375cc99d9f64ac24e972eb421b8bc09c6a /libempathy-gtk
parentb768818115dbc3a0b570500a74bc9c8ded62eea5 (diff)
downloadgsoc2013-empathy-10edf350020350475ece049d9c8fd969f70cf5c5.tar
gsoc2013-empathy-10edf350020350475ece049d9c8fd969f70cf5c5.tar.gz
gsoc2013-empathy-10edf350020350475ece049d9c8fd969f70cf5c5.tar.bz2
gsoc2013-empathy-10edf350020350475ece049d9c8fd969f70cf5c5.tar.lz
gsoc2013-empathy-10edf350020350475ece049d9c8fd969f70cf5c5.tar.xz
gsoc2013-empathy-10edf350020350475ece049d9c8fd969f70cf5c5.tar.zst
gsoc2013-empathy-10edf350020350475ece049d9c8fd969f70cf5c5.zip
Move empathy_call_* util functions to libempathy-gtk
Since we want to pop up a dialog when starting a call fails.
Diffstat (limited to 'libempathy-gtk')
-rw-r--r--libempathy-gtk/Makefile.am2
-rw-r--r--libempathy-gtk/empathy-call-utils.c169
-rw-r--r--libempathy-gtk/empathy-call-utils.h46
-rw-r--r--libempathy-gtk/empathy-contact-menu.c1
-rw-r--r--libempathy-gtk/empathy-individual-menu.c1
-rw-r--r--libempathy-gtk/empathy-new-call-dialog.c1
6 files changed, 220 insertions, 0 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index 058ca8569..390d37cbb 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -38,6 +38,7 @@ libempathy_gtk_handwritten_source = \
empathy-account-widget.c \
empathy-avatar-chooser.c \
empathy-avatar-image.c \
+ empathy-call-utils.c \
empathy-cell-renderer-activatable.c \
empathy-cell-renderer-expander.c \
empathy-cell-renderer-text.c \
@@ -98,6 +99,7 @@ libempathy_gtk_headers = \
empathy-account-widget.h \
empathy-avatar-chooser.h \
empathy-avatar-image.h \
+ empathy-call-utils.h \
empathy-cell-renderer-activatable.h \
empathy-cell-renderer-expander.h \
empathy-cell-renderer-text.h \
diff --git a/libempathy-gtk/empathy-call-utils.c b/libempathy-gtk/empathy-call-utils.c
new file mode 100644
index 000000000..d94e62400
--- /dev/null
+++ b/libempathy-gtk/empathy-call-utils.c
@@ -0,0 +1,169 @@
+/*
+ * Copyright (C) 2011 Collabora Ltd.
+ *
+ * The code contained in this file is free software; you can redistribute
+ * it and/or modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either version
+ * 2.1 of the License, or (at your option) any later version.
+ *
+ * This file is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this code; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ *
+ * Authors: Emilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>
+ */
+
+#include "config.h"
+
+#include <telepathy-glib/telepathy-glib.h>
+
+#if HAVE_CALL
+ #include <telepathy-yell/telepathy-yell.h>
+#endif
+
+#include "empathy-call-utils.h"
+
+#define DEBUG_FLAG EMPATHY_DEBUG_OTHER
+#include <libempathy/empathy-debug.h>
+
+#if HAVE_CALL
+GHashTable *
+empathy_call_create_call_request (EmpathyContact *contact,
+ gboolean initial_audio,
+ gboolean initial_video)
+{
+ return tp_asv_new (
+ TP_PROP_CHANNEL_CHANNEL_TYPE, G_TYPE_STRING,
+ TPY_IFACE_CHANNEL_TYPE_CALL,
+ TP_PROP_CHANNEL_TARGET_HANDLE_TYPE, G_TYPE_UINT,
+ TP_HANDLE_TYPE_CONTACT,
+ TP_PROP_CHANNEL_TARGET_HANDLE, G_TYPE_UINT,
+ empathy_contact_get_handle (contact),
+ TPY_PROP_CHANNEL_TYPE_CALL_INITIAL_AUDIO, G_TYPE_BOOLEAN,
+ initial_audio,
+ TPY_PROP_CHANNEL_TYPE_CALL_INITIAL_VIDEO, G_TYPE_BOOLEAN,
+ initial_video,
+ NULL);
+}
+#endif
+
+GHashTable *
+empathy_call_create_streamed_media_request (EmpathyContact *contact,
+ gboolean initial_audio,
+ gboolean initial_video)
+{
+ return tp_asv_new (
+ TP_PROP_CHANNEL_CHANNEL_TYPE, G_TYPE_STRING,
+ TP_IFACE_CHANNEL_TYPE_STREAMED_MEDIA,
+ TP_PROP_CHANNEL_TARGET_HANDLE_TYPE, G_TYPE_UINT,
+ TP_HANDLE_TYPE_CONTACT,
+ TP_PROP_CHANNEL_TARGET_HANDLE, G_TYPE_UINT,
+ empathy_contact_get_handle (contact),
+ TP_PROP_CHANNEL_TYPE_STREAMED_MEDIA_INITIAL_AUDIO, G_TYPE_BOOLEAN,
+ initial_audio,
+ TP_PROP_CHANNEL_TYPE_STREAMED_MEDIA_INITIAL_VIDEO, G_TYPE_BOOLEAN,
+ initial_video,
+ NULL);
+}
+
+static void
+create_streamed_media_channel_cb (GObject *source,
+ GAsyncResult *result,
+ gpointer user_data)
+{
+ GError *error = NULL;
+
+ if (!tp_account_channel_request_create_channel_finish (
+ TP_ACCOUNT_CHANNEL_REQUEST (source),
+ result,
+ &error))
+ {
+ DEBUG ("Failed to create StreamedMedia channel: %s", error->message);
+ g_error_free (error);
+ }
+}
+
+#if HAVE_CALL
+static void
+create_call_channel_cb (GObject *source,
+ GAsyncResult *result,
+ gpointer user_data)
+{
+ TpAccountChannelRequest *streamed_media_req = user_data;
+ GError *error = NULL;
+
+ if (tp_account_channel_request_create_channel_finish (
+ TP_ACCOUNT_CHANNEL_REQUEST (source), result, &error))
+ {
+ g_object_unref (streamed_media_req);
+ return;
+ }
+
+ DEBUG ("Failed to create Call channel: %s", error->message);
+
+ if (error->code != TP_ERROR_NOT_IMPLEMENTED)
+ return;
+
+ DEBUG ("Let's try with an StreamedMedia channel");
+ g_error_free (error);
+ tp_account_channel_request_create_channel_async (streamed_media_req, NULL, NULL,
+ create_streamed_media_channel_cb,
+ NULL);
+}
+#endif
+
+void
+empathy_call_new_with_streams (EmpathyContact *contact,
+ gboolean initial_audio,
+ gboolean initial_video,
+ gint64 timestamp)
+{
+#if HAVE_CALL
+ GHashTable *call_request, *streamed_media_request;
+ TpAccount *account;
+ TpAccountChannelRequest *call_req, *streamed_media_req;
+
+ call_request = empathy_call_create_call_request (contact,
+ initial_audio,
+ initial_video);
+
+ streamed_media_request = empathy_call_create_streamed_media_request (
+ contact, initial_audio, initial_video);
+
+ account = empathy_contact_get_account (contact);
+
+ call_req = tp_account_channel_request_new (account, call_request, timestamp);
+ streamed_media_req = tp_account_channel_request_new (account,
+ streamed_media_request,
+ timestamp);
+
+ tp_account_channel_request_create_channel_async (call_req, NULL, NULL,
+ create_call_channel_cb,
+ streamed_media_req);
+
+ g_hash_table_unref (call_request);
+ g_hash_table_unref (streamed_media_request);
+ g_object_unref (call_req);
+#else
+ GHashTable *request;
+ TpAccountChannelRequest *req;
+
+ request = empathy_call_create_streamed_media_request (contact,
+ initial_audio,
+ initial_video);
+
+ req = tp_account_channel_request_new (account, request, timestamp);
+
+ tp_account_channel_request_create_channel_async (req, NULL, NULL,
+ create_streamed_media_channel_cb,
+ NULL);
+
+ g_hash_table_unref (request);
+ g_object_unref (req);
+#endif
+}
diff --git a/libempathy-gtk/empathy-call-utils.h b/libempathy-gtk/empathy-call-utils.h
new file mode 100644
index 000000000..1bea52f6a
--- /dev/null
+++ b/libempathy-gtk/empathy-call-utils.h
@@ -0,0 +1,46 @@
+/*
+ * Copyright (C) 2011 Collabora Ltd.
+ *
+ * The code contained in this file is free software; you can redistribute
+ * it and/or modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either version
+ * 2.1 of the License, or (at your option) any later version.
+ *
+ * This file is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Lesser General Public License for more details.
+ *
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this code; if not, write to the Free Software
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ *
+ * Authors: Emilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>
+ */
+
+#ifndef __EMPATHY_CALL_UTILS_H__
+#define __EMPATHY_CALL_UTILS_H__
+
+#include <libempathy/empathy-contact.h>
+
+G_BEGIN_DECLS
+
+/* Calls */
+void empathy_call_new_with_streams (EmpathyContact *contact,
+ gboolean initial_audio,
+ gboolean initial_video,
+ gint64 timestamp);
+
+GHashTable * empathy_call_create_call_request (
+ EmpathyContact *contact,
+ gboolean initial_audio,
+ gboolean initial_video);
+
+GHashTable * empathy_call_create_streamed_media_request (
+ EmpathyContact *contact,
+ gboolean initial_audio,
+ gboolean initial_video);
+
+G_END_DECLS
+
+#endif /* __EMPATHY_CALL_UTILS_H__ */
diff --git a/libempathy-gtk/empathy-contact-menu.c b/libempathy-gtk/empathy-contact-menu.c
index 64056eebf..a9504e085 100644
--- a/libempathy-gtk/empathy-contact-menu.c
+++ b/libempathy-gtk/empathy-contact-menu.c
@@ -39,6 +39,7 @@
#include "empathy-contact-dialogs.h"
#include "empathy-ui-utils.h"
#include "empathy-share-my-desktop.h"
+#include "empathy-call-utils.h"
static GtkWidget *empathy_contact_block_menu_item_new (EmpathyContact *);
diff --git a/libempathy-gtk/empathy-individual-menu.c b/libempathy-gtk/empathy-individual-menu.c
index 7cab792a2..fad18b3f3 100644
--- a/libempathy-gtk/empathy-individual-menu.c
+++ b/libempathy-gtk/empathy-individual-menu.c
@@ -46,6 +46,7 @@
#include "empathy-ui-utils.h"
#include "empathy-share-my-desktop.h"
#include "empathy-linking-dialog.h"
+#include "empathy-call-utils.h"
#define GET_PRIV(obj) EMPATHY_GET_PRIV (obj, EmpathyIndividualMenu)
diff --git a/libempathy-gtk/empathy-new-call-dialog.c b/libempathy-gtk/empathy-new-call-dialog.c
index 3f0264660..cbfbb9569 100644
--- a/libempathy-gtk/empathy-new-call-dialog.c
+++ b/libempathy-gtk/empathy-new-call-dialog.c
@@ -44,6 +44,7 @@
#include "empathy-new-call-dialog.h"
#include "empathy-account-chooser.h"
+#include "empathy-call-utils.h"
static EmpathyNewCallDialog *dialog_singleton = NULL;