aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2010-07-08 20:35:53 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2010-07-08 20:35:53 +0800
commit0637683a2f89087f49fa0d91e44b04ed26d72ba3 (patch)
tree7f0d367d965831cc45b3091d28b7fdee8ebb011f /libempathy-gtk
parent526cac765322aa7516d46d735fc9b5f1c4f2c228 (diff)
parent6b1d4251dc32cf7c75871002a1f8163af9775f65 (diff)
downloadgsoc2013-empathy-0637683a2f89087f49fa0d91e44b04ed26d72ba3.tar
gsoc2013-empathy-0637683a2f89087f49fa0d91e44b04ed26d72ba3.tar.gz
gsoc2013-empathy-0637683a2f89087f49fa0d91e44b04ed26d72ba3.tar.bz2
gsoc2013-empathy-0637683a2f89087f49fa0d91e44b04ed26d72ba3.tar.lz
gsoc2013-empathy-0637683a2f89087f49fa0d91e44b04ed26d72ba3.tar.xz
gsoc2013-empathy-0637683a2f89087f49fa0d91e44b04ed26d72ba3.tar.zst
gsoc2013-empathy-0637683a2f89087f49fa0d91e44b04ed26d72ba3.zip
Merge branch 'gtk3-621753'
Diffstat (limited to 'libempathy-gtk')
-rw-r--r--libempathy-gtk/Makefile.am8
-rw-r--r--libempathy-gtk/empathy-notify-manager.h2
2 files changed, 8 insertions, 2 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index 43763d56c..6fa8202dd 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -6,8 +6,10 @@ AM_CPPFLAGS = \
-I$(top_srcdir) \
-DDATADIR=\""$(datadir)"\" \
-DPKGDATADIR=\""$(pkgdatadir)"\" \
- $(LIBEMPATHYGTK_CFLAGS) \
+ $(EMPATHY_CFLAGS) \
+ $(GTK_CFLAGS) \
$(LIBNOTIFY_CFLAGS) \
+ $(CANBERRA_CFLAGS) \
$(ENCHANT_CFLAGS) \
$(LIBCHAMPLAIN_CFLAGS) \
$(GEOCLUE_CFLAGS) \
@@ -129,8 +131,10 @@ nodist_libempathy_gtk_la_SOURCES =\
$(BUILT_SOURCES)
libempathy_gtk_la_LIBADD = \
- $(LIBEMPATHYGTK_LIBS) \
+ $(EMPATHY_LIBS) \
+ $(GTK_LIBS) \
$(LIBNOTIFY_LIBS) \
+ $(CANBERRA_LIBS) \
$(ENCHANT_LIBS) \
$(LIBCHAMPLAIN_LIBS) \
$(GEOCLUE_LIBS) \
diff --git a/libempathy-gtk/empathy-notify-manager.h b/libempathy-gtk/empathy-notify-manager.h
index ff62a872a..f7c5e4c5a 100644
--- a/libempathy-gtk/empathy-notify-manager.h
+++ b/libempathy-gtk/empathy-notify-manager.h
@@ -23,6 +23,8 @@
#include <glib-object.h>
+#include <libempathy/empathy-contact.h>
+
G_BEGIN_DECLS
#define EMPATHY_NOTIFY_MANAGER_CAP_ACTIONS "actions"