aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/empathy-chat.c
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-10-13 21:00:29 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-10-13 21:00:29 +0800
commitd00adf45ea54086a8d1d29090639b5beb3f88b34 (patch)
tree9cc7756b93e51e5c9ba250e82164316e8778e3f3 /libempathy-gtk/empathy-chat.c
parent0ab84cc3ffe6129ae40ad436eb62fccbd52b00ad (diff)
downloadgsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar.gz
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar.bz2
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar.lz
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar.xz
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.tar.zst
gsoc2013-empathy-d00adf45ea54086a8d1d29090639b5beb3f88b34.zip
Don't use deprecated GtkTooltips API. Add commented out lines in
2007-10-13 Xavier Claessens <xclaesse@gmail.com> * libempathy-gtk/empathy-chat-view.h: * libempathy-gtk/empathy-main-window.c: * libempathy-gtk/empathy-chat.c: * libempathy-gtk/empathy-chat-window.c: * libempathy-gtk/empathy-chat-view.c: * libempathy/empathy-log-manager.c: * libempathy/empathy-time.c: * libempathy/empathy-tp-chat.c: * libempathy/empathy-time.h: * libempathy/empathy-message.c: * libempathy/empathy-message.h: * libempathy/empathy-presence.c: * configure.ac: Don't use deprecated GtkTooltips API. Add commented out lines in configure.ac to disable GLib and GTK deprecated symbols. Replace EmpathyTime by time_t which is more appropriate for timestamps. * doc/*: Updated. svn path=/trunk/; revision=371
Diffstat (limited to 'libempathy-gtk/empathy-chat.c')
-rw-r--r--libempathy-gtk/empathy-chat.c10
1 files changed, 3 insertions, 7 deletions
diff --git a/libempathy-gtk/empathy-chat.c b/libempathy-gtk/empathy-chat.c
index f68a82826..9dd75c2c7 100644
--- a/libempathy-gtk/empathy-chat.c
+++ b/libempathy-gtk/empathy-chat.c
@@ -67,7 +67,6 @@ struct _EmpathyChatPriv {
EmpathyLogManager *log_manager;
EmpathyTpChat *tp_chat;
EmpathyChatWindow *window;
- GtkTooltips *tooltips;
guint composing_stop_timeout_id;
gboolean sensitive;
gchar *id;
@@ -76,7 +75,7 @@ struct _EmpathyChatPriv {
GList *compositors;
guint scroll_idle_id;
gboolean first_tp_chat;
- EmpathyTime last_log_timestamp;
+ time_t last_log_timestamp;
/* Used to automatically shrink a window that has temporarily
* grown due to long input.
*/
@@ -237,7 +236,6 @@ empathy_chat_init (EmpathyChat *chat)
priv->manager = empathy_contact_manager_new ();
priv->log_manager = empathy_log_manager_new ();
- priv->tooltips = g_object_ref_sink (gtk_tooltips_new ());
priv->default_window_height = -1;
priv->vscroll_visible = FALSE;
priv->sensitive = TRUE;
@@ -303,7 +301,6 @@ chat_finalize (GObject *object)
g_object_unref (chat->account);
g_object_unref (priv->manager);
g_object_unref (priv->log_manager);
- g_object_unref (priv->tooltips);
if (priv->tp_chat) {
g_object_unref (priv->tp_chat);
@@ -402,7 +399,7 @@ chat_message_received_cb (EmpathyTpChat *tp_chat,
{
EmpathyChatPriv *priv;
EmpathyContact *sender;
- EmpathyTime timestamp;
+ time_t timestamp;
priv = GET_PRIV (chat);
@@ -927,8 +924,7 @@ chat_text_populate_popup_cb (GtkTextView *view,
smiley_menu = empathy_chat_view_get_smiley_menu (
G_CALLBACK (chat_insert_smiley_activate_cb),
- chat,
- priv->tooltips);
+ chat);
gtk_menu_item_set_submenu (GTK_MENU_ITEM (item), smiley_menu);
/* Add the spell check menu item. */