aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
authorPierre-Luc Beaudoin <pierre-luc.beaudoin@collabora.co.uk>2009-05-30 03:15:42 +0800
committerPierre-Luc Beaudoin <pierre-luc.beaudoin@collabora.co.uk>2009-06-01 23:35:32 +0800
commit7a1fd4ecfdb3af30a23b4cd028a5c7402f1f6a38 (patch)
tree493c9599dec4c0a30254cc637200886ccbce1168 /libempathy-gtk/Makefile.am
parent6db41c2d2576e35bfe086a9a96e5014a7a8ff6db (diff)
downloadgsoc2013-empathy-7a1fd4ecfdb3af30a23b4cd028a5c7402f1f6a38.tar
gsoc2013-empathy-7a1fd4ecfdb3af30a23b4cd028a5c7402f1f6a38.tar.gz
gsoc2013-empathy-7a1fd4ecfdb3af30a23b4cd028a5c7402f1f6a38.tar.bz2
gsoc2013-empathy-7a1fd4ecfdb3af30a23b4cd028a5c7402f1f6a38.tar.lz
gsoc2013-empathy-7a1fd4ecfdb3af30a23b4cd028a5c7402f1f6a38.tar.xz
gsoc2013-empathy-7a1fd4ecfdb3af30a23b4cd028a5c7402f1f6a38.tar.zst
gsoc2013-empathy-7a1fd4ecfdb3af30a23b4cd028a5c7402f1f6a38.zip
Don't build the file instead of #if the whole file
Diffstat (limited to 'libempathy-gtk/Makefile.am')
-rw-r--r--libempathy-gtk/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index b31bd3f4c..4fd0fa562 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -47,7 +47,6 @@ libempathy_gtk_handwritten_source = \
empathy-video-src.c \
empathy-video-widget.c \
empathy-irc-network-dialog.c \
- empathy-location-manager.c \
empathy-log-window.c \
empathy-new-message-dialog.c \
empathy-presence-chooser.c \
@@ -106,7 +105,6 @@ libempathy_gtk_headers = \
empathy-video-widget.h \
empathy-images.h \
empathy-irc-network-dialog.h \
- empathy-location-manager.h \
empathy-log-window.h \
empathy-new-message-dialog.h \
empathy-presence-chooser.h \
@@ -119,6 +117,14 @@ libempathy_gtk_headers = \
empathy-theme-manager.h \
empathy-ui-utils.h
+if HAVE_GEOCLUE
+libempathy_gtk_handwritten_source += \
+ empathy-location-manager.c
+
+libempathy_gtk_headers += \
+ empathy-location-manager.h
+endif
+
check_c_sources = \
$(libempathy_gtk_handwritten_source) \
$(libempathy_gtk_headers)