aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
authorJavier Jardón <jjardon@gnome.org>2010-01-18 04:05:38 +0800
committerJonny Lamb <jonnylamb@gnome.org>2010-01-18 05:57:13 +0800
commitf687777360a213c638374c1d497ca849717ce174 (patch)
tree3a6740e80f8e240d11942c99b028838b095eed6c /libempathy-gtk/Makefile.am
parent6a1aecd8b35cee47c56326d4babc46a146a91be0 (diff)
downloadgsoc2013-empathy-f687777360a213c638374c1d497ca849717ce174.tar
gsoc2013-empathy-f687777360a213c638374c1d497ca849717ce174.tar.gz
gsoc2013-empathy-f687777360a213c638374c1d497ca849717ce174.tar.bz2
gsoc2013-empathy-f687777360a213c638374c1d497ca849717ce174.tar.lz
gsoc2013-empathy-f687777360a213c638374c1d497ca849717ce174.tar.xz
gsoc2013-empathy-f687777360a213c638374c1d497ca849717ce174.tar.zst
gsoc2013-empathy-f687777360a213c638374c1d497ca849717ce174.zip
Support silent build rules with automake 1.11
Support silent build rules, requires at least automake-1.11. Disable by either passing --disable-silent-rules to configure or passing V=1 to make. Fixes https://bugzilla.gnome.org/show_bug.cgi?id=585364 Signed-off-by: Jonny Lamb <jonnylamb@gnome.org>
Diffstat (limited to 'libempathy-gtk/Makefile.am')
-rw-r--r--libempathy-gtk/Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index 2dd50bb6e..5015e0a04 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -1,4 +1,3 @@
-include $(top_srcdir)/tools/shave.mk
include $(top_srcdir)/tools/flymake.mk
AM_CPPFLAGS = \
@@ -164,27 +163,27 @@ ui_DATA = \
empathy-search-bar.ui
empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
- $(QUIET_GEN)( cd $(srcdir) && \
+ $(AM_V_GEN)( cd $(srcdir) && \
sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
$(libempathy_gtk_la_SOURCES) ) \
| sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
- if cmp -s $@.tmp $@; then \
+ @if cmp -s $@.tmp $@; then \
rm $@.tmp; \
else \
mv $@.tmp $@; \
fi
%-marshal.h: %-marshal.list Makefile
- $(QUIET_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+ $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
%-marshal.c: %-marshal.list Makefile
- $(QUIET_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
+ $(AM_V_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
$(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
- $(QUIET_GEN)true
+ $(AM_V_GEN)true
stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
- $(QUIET_GEN)(cd $(srcdir) \
+ $(AM_V_GEN)(cd $(srcdir) \
&& glib-mkenums \
--fhead "#ifndef __LIBEMPATHY_GTK_ENUM_TYPES_H__\n" \
--fhead "#define __LIBEMPATHY_GTK_ENUM_TYPES_H__ 1\n\n" \
@@ -201,7 +200,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
&& echo timestamp > $(@F)
empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
- $(QUIET_GEN)(cd $(srcdir) \
+ $(AM_V_GEN)(cd $(srcdir) \
&& glib-mkenums \
--fhead "#include <config.h>\n" \
--fhead "#include <glib-object.h>\n" \