aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
authorDanielle Madeley <danielle.madeley@collabora.co.uk>2011-08-01 11:04:15 +0800
committerDanielle Madeley <danielle.madeley@collabora.co.uk>2011-08-01 11:04:15 +0800
commite3d0a1862508fad3d16585b0210a2a9328453c2f (patch)
tree6b2e374f716488ff84e0ef5cf425dd784f0c42ea /libempathy-gtk/Makefile.am
parentd890a28335477c0e18cd68264467e7be45496388 (diff)
downloadgsoc2013-empathy-e3d0a1862508fad3d16585b0210a2a9328453c2f.tar
gsoc2013-empathy-e3d0a1862508fad3d16585b0210a2a9328453c2f.tar.gz
gsoc2013-empathy-e3d0a1862508fad3d16585b0210a2a9328453c2f.tar.bz2
gsoc2013-empathy-e3d0a1862508fad3d16585b0210a2a9328453c2f.tar.lz
gsoc2013-empathy-e3d0a1862508fad3d16585b0210a2a9328453c2f.tar.xz
gsoc2013-empathy-e3d0a1862508fad3d16585b0210a2a9328453c2f.tar.zst
gsoc2013-empathy-e3d0a1862508fad3d16585b0210a2a9328453c2f.zip
Abstract WebKit string parsers into empathy-webkit-utils
This file is currently optionally built, but if the logviewer is going to depend on WebKit, maybe that's a bad idea? Maybe we should just make WebKit required (this will probably happen when we require Adium themes in the future).
Diffstat (limited to 'libempathy-gtk/Makefile.am')
-rw-r--r--libempathy-gtk/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index 7023ecfe5..f12230def 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -279,16 +279,23 @@ endif
if HAVE_WEBKIT
libempathy_gtk_handwritten_source += \
empathy-plist.c \
- empathy-theme-adium.c
+ empathy-theme-adium.c \
+ empathy-webkit-utils.c \
+ $(NULL)
libempathy_gtk_headers += \
empathy-plist.h \
- empathy-theme-adium.h
+ empathy-theme-adium.h \
+ empathy-webkit-utils.h \
+ $(NULL)
else
EXTRA_DIST += \
empathy-plist.c \
empathy-plist.h \
empathy-theme-adium.c \
- empathy-theme-adium.h
+ empathy-theme-adium.h \
+ empathy-webkit-utils.c \
+ empathy-webkit-utils.h \
+ $(NULL)
endif
CLEANFILES = \