aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
authorDanielle Madeley <danielle.madeley@collabora.co.uk>2011-08-16 11:38:23 +0800
committerDanielle Madeley <danielle.madeley@collabora.co.uk>2011-08-16 11:38:23 +0800
commit6cf57d879945059cd974a3ee6d02d81edff47438 (patch)
tree04ba16a72ba34bfa0b4cee7788c2db2b5a70a43e /libempathy-gtk/Makefile.am
parentd5024011258a052ea3b88e95d0098f3901bb98cc (diff)
downloadgsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar.gz
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar.bz2
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar.lz
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar.xz
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.tar.zst
gsoc2013-empathy-6cf57d879945059cd974a3ee6d02d81edff47438.zip
Make WebKit compulsory
It is now required for the log viewer, furthermore it will be required once we remove non-adium themes.
Diffstat (limited to 'libempathy-gtk/Makefile.am')
-rw-r--r--libempathy-gtk/Makefile.am37
1 files changed, 11 insertions, 26 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index f12230def..fd895d508 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -14,7 +14,6 @@ AM_CPPFLAGS = \
$(GEOCLUE_CFLAGS) \
$(GEOCODE_CFLAGS) \
$(MEEGO_CFLAGS) \
- $(WEBKIT_CFLAGS) \
$(CHEESE_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
@@ -88,7 +87,11 @@ libempathy_gtk_handwritten_source = \
empathy-theme-irc.c \
empathy-theme-manager.c \
empathy-tls-dialog.c \
- empathy-ui-utils.c
+ empathy-ui-utils.c \
+ empathy-plist.c \
+ empathy-theme-adium.c \
+ empathy-webkit-utils.c \
+ $(NULL)
libempathy_gtk_headers = \
empathy-account-chooser.h \
@@ -150,7 +153,12 @@ libempathy_gtk_headers = \
empathy-theme-irc.h \
empathy-theme-manager.h \
empathy-tls-dialog.h \
- empathy-ui-utils.h
+ empathy-ui-utils.h \
+ empathy-plist.h \
+ empathy-theme-adium.h \
+ empathy-webkit-utils.h \
+ $(NULL)
+
libempathy_gtk_la_SOURCES = \
$(libempathy_gtk_handwritten_source) \
@@ -173,7 +181,6 @@ libempathy_gtk_la_LIBADD = \
$(GEOCODE_LIBS) \
$(GCR_LIBS) \
$(MEEGO_LIBS) \
- $(WEBKIT_LIBS) \
$(CHEESE_LIBS) \
$(top_builddir)/libempathy/libempathy.la
@@ -276,28 +283,6 @@ EXTRA_DIST += \
empathy-location-manager.h
endif
-if HAVE_WEBKIT
-libempathy_gtk_handwritten_source += \
- empathy-plist.c \
- empathy-theme-adium.c \
- empathy-webkit-utils.c \
- $(NULL)
-libempathy_gtk_headers += \
- empathy-plist.h \
- empathy-theme-adium.h \
- empathy-webkit-utils.h \
- $(NULL)
-else
-EXTRA_DIST += \
- empathy-plist.c \
- empathy-plist.h \
- empathy-theme-adium.c \
- empathy-theme-adium.h \
- empathy-webkit-utils.c \
- empathy-webkit-utils.h \
- $(NULL)
-endif
-
CLEANFILES = \
$(BUILT_SOURCES) \
stamp-empathy-gtk-enum-types.h