aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2008-02-10 05:07:02 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2008-02-10 05:07:02 +0800
commitf82a1cfd7d318c35cf9fb696d38d63c9d5a899d2 (patch)
treeeee1f5cd5662a4ab6ab9a8fcbc049b6eb16dfc3e /libempathy-gtk/Makefile.am
parent8566eedace4bc9ffe440e3bd057b08a9f3810d09 (diff)
downloadgsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar.gz
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar.bz2
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar.lz
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar.xz
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.tar.zst
gsoc2013-empathy-f82a1cfd7d318c35cf9fb696d38d63c9d5a899d2.zip
Generate marshal.list thanks to gabble black magic.
svn path=/trunk/; revision=614
Diffstat (limited to 'libempathy-gtk/Makefile.am')
-rw-r--r--libempathy-gtk/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index 987e28f2e..6d5eeab7d 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -6,6 +6,9 @@ AM_CPPFLAGS = \
$(WARN_CFLAGS)
BUILT_SOURCES = \
+ empathy-gtk-marshal.h \
+ empathy-gtk-marshal.c \
+ empathy-gtk-marshal.list \
empathy-gtk-enum-types.h \
empathy-gtk-enum-types.c
@@ -137,6 +140,24 @@ glade_DATA = \
empathy-chat.glade \
empathy-new-message-dialog.glade
+empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
+ ( cd $(srcdir) && \
+ sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:]]*__[[:upper:]_]*\).*/\1/p' \
+ $(libempathy_gtk_la_SOURCES) ) \
+ | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
+ if cmp -s $@.tmp $@; then \
+ rm $@.tmp; \
+ else \
+ mv $@.tmp $@; \
+ fi
+
+%-marshal.h: %-marshal.list Makefile
+ $(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+
+%-marshal.c: %-marshal.list Makefile
+ echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
+ $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
+
empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
@true
stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)