aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
authorPierre-Luc Beaudoin <pierre-luc.beaudoin@collabora.co.uk>2009-06-09 03:10:57 +0800
committerPierre-Luc Beaudoin <pierre-luc.beaudoin@collabora.co.uk>2009-06-09 05:02:32 +0800
commitb28c2c17566ac07565b98e6720c7a6a5ec927ad1 (patch)
treee7d805277f707c69bad625779f5cd7ec3a511cb6 /libempathy-gtk/Makefile.am
parentcc548789733a60b077718c022b6b0e03fc793857 (diff)
downloadgsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar.gz
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar.bz2
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar.lz
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar.xz
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar.zst
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.zip
Distribute conditionally built files
Diffstat (limited to 'libempathy-gtk/Makefile.am')
-rw-r--r--libempathy-gtk/Makefile.am20
1 files changed, 12 insertions, 8 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index 80c9a792d..c3d085fae 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -118,14 +118,6 @@ libempathy_gtk_headers = \
empathy-theme-manager.h \
empathy-ui-utils.h
-if HAVE_GEOCLUE
-libempathy_gtk_handwritten_source += \
- empathy-location-manager.c
-
-libempathy_gtk_headers += \
- empathy-location-manager.h
-endif
-
check_c_sources = \
$(libempathy_gtk_handwritten_source) \
$(libempathy_gtk_headers)
@@ -218,6 +210,18 @@ pkgconfig_DATA = libempathy-gtk.pc
EXTRA_DIST = \
$(ui_DATA)
+if HAVE_GEOCLUE
+libempathy_gtk_handwritten_source += \
+ empathy-location-manager.c
+
+libempathy_gtk_headers += \
+ empathy-location-manager.h
+else
+EXTRA_DIST += \
+ empathy-location-manager.c \
+ empathy-location-manager.h
+endif
+
CLEANFILES = \
$(BUILT_SOURCES) \
stamp-empathy-gtk-enum-types.h