aboutsummaryrefslogtreecommitdiffstats
path: root/docs/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-11-16 01:25:13 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-11-16 01:25:13 +0800
commit1b97222821b7362cce1a68d6ba54106c66f5b932 (patch)
tree03d841fdb3e8af93f0c5ab9cc07392be8d05de55 /docs/libempathy-gtk/Makefile.am
parentc9721056606b7d03de34eabcf8ad17acac52cab3 (diff)
downloadgsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar.gz
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar.bz2
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar.lz
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar.xz
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.tar.zst
gsoc2013-empathy-1b97222821b7362cce1a68d6ba54106c66f5b932.zip
Remove doc directory and replace it with a better gtk-doc in docs. More
2007-11-15 Xavier Claessens <xclaesse@gmail.com> * docs/*: * doc/*: * configure.ac: * Makefile.am: Remove doc directory and replace it with a better gtk-doc in docs. More files are auto-generated, we have less files on SVN. svn path=/trunk/; revision=439
Diffstat (limited to 'docs/libempathy-gtk/Makefile.am')
-rw-r--r--docs/libempathy-gtk/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/docs/libempathy-gtk/Makefile.am b/docs/libempathy-gtk/Makefile.am
new file mode 100644
index 000000000..a44a2861d
--- /dev/null
+++ b/docs/libempathy-gtk/Makefile.am
@@ -0,0 +1,55 @@
+NULL =
+
+AUTOMAKE_OPTIONS = 1.6
+
+# The name of the module.
+DOC_MODULE=libempathy-gtk
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=libempathy-gtk-docs.sgml
+
+# Extra options to supply to gtkdoc-scan
+SCAN_OPTIONS=--deprecated-guards="G_DISABLE_DEPRECATED"
+
+# The directory containing the source code. Relative to $(srcdir)
+DOC_SOURCE_DIR=$(top_srcdir)/libempathy-gtk
+
+HFILE_GLOB=$(top_srcdir)/libempathy-gtk/*.h
+CFILE_GLOB=$(top_srcdir)/libempathy-gtk/*.c
+
+# Headers to ignore
+IGNORE_HFILES= \
+ $(NULL)
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed
+# if $(DOC_MODULE).types is non-empty.
+GTKDOC_CFLAGS = \
+ -I$(srcdir) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/libempathy-gtk \
+ -I$(top_builddir) \
+ -I$(top_builddir)/libempathy-gtk \
+ $(EMPATHY_CFLAGS) \
+ $(NULL)
+
+GTKDOC_LIBS = \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la \
+ $(top_builddir)/libempathy/libempathy.la \
+ $(EMPATHY_LIBS) \
+ $(NULL)
+
+# Extra options to supply to gtkdoc-mkdb
+MKDB_OPTIONS = --output-format=xml --sgml-mode
+
+# Images to copy into HTML directory
+HTML_IMAGES =
+
+content_files = \
+ version.xml
+
+extra_files = version.xml.in
+
+include $(top_srcdir)/gtk-doc.make
+
+EXTRA_DIST += \
+ version.xml.in