aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorEmanuele Aina <emanuele.aina@collabora.com>2012-03-06 07:04:51 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-03-06 23:14:47 +0800
commitaeab15ec37370f3c3aa8b4e1a4aec480109a6803 (patch)
tree4c79d77e6f5b877208c0706f70f448a89e00dd62 /data/Makefile.am
parent912a95b7ceb56e16854fa09af9c31cb33b6303ca (diff)
downloadgsoc2013-empathy-aeab15ec37370f3c3aa8b4e1a4aec480109a6803.tar
gsoc2013-empathy-aeab15ec37370f3c3aa8b4e1a4aec480109a6803.tar.gz
gsoc2013-empathy-aeab15ec37370f3c3aa8b4e1a4aec480109a6803.tar.bz2
gsoc2013-empathy-aeab15ec37370f3c3aa8b4e1a4aec480109a6803.tar.lz
gsoc2013-empathy-aeab15ec37370f3c3aa8b4e1a4aec480109a6803.tar.xz
gsoc2013-empathy-aeab15ec37370f3c3aa8b4e1a4aec480109a6803.tar.zst
gsoc2013-empathy-aeab15ec37370f3c3aa8b4e1a4aec480109a6803.zip
Run from the source directory without installing
Use the tools/empathy-env wrapper to set an appropriate environment and launch the compiled programs without installing them. https://bugzilla.gnome.org/show_bug.cgi?id=671447
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index f3da574ae..a2be750cf 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -15,6 +15,13 @@ gsettings_SCHEMAS = $(gsettings_files:.xml.in=.xml)
@INTLTOOL_XML_NOMERGE_RULE@
@GSETTINGS_RULES@
+# We need to compile schemas at make time
+# to run from source tree
+gschemas.compiled: $(gsettings_SCHEMAS:.xml=.valid)
+ $(AM_V_GEN) $(GLIB_COMPILE_SCHEMAS) --targetdir=. .
+
+all-local: gschemas.compiled
+
convertdir = $(datarootdir)/GConf/gsettings
convert_DATA = \
empathy.convert
@@ -82,4 +89,5 @@ DISTCLEANFILES = \
$(schemas_DATA) \
$(servicefile_DATA) \
$(gsettings_SCHEMAS) \
+ gschemas.compiled \
$(NULL)