aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorDanielle Madeley <danielle.madeley@collabora.co.uk>2011-07-29 12:23:21 +0800
committerDanielle Madeley <danielle.madeley@collabora.co.uk>2011-07-29 12:23:21 +0800
commite1ae13450cf3ad12df82bd6a2111eedd6d169ef7 (patch)
treef924dbe81d9b1881af8ba6c574b1d0e4a348ece2 /data/Makefile.am
parente10a0655a4eb8c36f232d533078bcf6b8e7fdbd0 (diff)
downloadgsoc2013-empathy-e1ae13450cf3ad12df82bd6a2111eedd6d169ef7.tar
gsoc2013-empathy-e1ae13450cf3ad12df82bd6a2111eedd6d169ef7.tar.gz
gsoc2013-empathy-e1ae13450cf3ad12df82bd6a2111eedd6d169ef7.tar.bz2
gsoc2013-empathy-e1ae13450cf3ad12df82bd6a2111eedd6d169ef7.tar.lz
gsoc2013-empathy-e1ae13450cf3ad12df82bd6a2111eedd6d169ef7.tar.xz
gsoc2013-empathy-e1ae13450cf3ad12df82bd6a2111eedd6d169ef7.tar.zst
gsoc2013-empathy-e1ae13450cf3ad12df82bd6a2111eedd6d169ef7.zip
Add a webview widget for displaying the log
The widget is currently bolted in alongside the existing log display widget for comparison. This includes some debugging cruft like showing the secret notebook tabs. The webview is populated from the store_events treestore, allowing all of the existing node-management and ordering code to be used. Attempting to replace this logic in Javascript was demonstratably too hard. This approach keeps the Javascript code down to the 4 GtkTreeModel signals. TODO: - icons - pretty printed dates - expanders - supporting smileys, links, etc. - using the correct font, etc. - removing the debugging
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 88de4f09b..d652ca9e5 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -58,7 +58,10 @@ clientfile_DATA = \
Empathy.FileTransfer.client
htmldir = $(datadir)/empathy
-html_DATA = Template.html
+html_DATA = \
+ Template.html \
+ empathy-log-window.html \
+ $(NULL)
EXTRA_DIST = \
$(convert_DATA) \