aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorJonny Lamb <jonny.lamb@collabora.co.uk>2009-08-25 20:24:06 +0800
committerSjoerd Simons <sjoerd.simons@collabora.co.uk>2009-08-25 20:59:29 +0800
commit4ddcac7537e2fb2404f95d45349b64e93d906724 (patch)
tree4dd7ef28046d51bb74879de9a59aedc8c16d16d6 /data/Makefile.am
parent0b21afc9c0dd2b3944637449cc36f3229e29275f (diff)
downloadgsoc2013-empathy-4ddcac7537e2fb2404f95d45349b64e93d906724.tar
gsoc2013-empathy-4ddcac7537e2fb2404f95d45349b64e93d906724.tar.gz
gsoc2013-empathy-4ddcac7537e2fb2404f95d45349b64e93d906724.tar.bz2
gsoc2013-empathy-4ddcac7537e2fb2404f95d45349b64e93d906724.tar.lz
gsoc2013-empathy-4ddcac7537e2fb2404f95d45349b64e93d906724.tar.xz
gsoc2013-empathy-4ddcac7537e2fb2404f95d45349b64e93d906724.tar.zst
gsoc2013-empathy-4ddcac7537e2fb2404f95d45349b64e93d906724.zip
Add client and service file for o.fd.Tp.Client.Empathy.
Signed-off-by: Jonny Lamb <jonny.lamb@collabora.co.uk>
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 43c3bb66c..83a575c42 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -15,6 +15,16 @@ streamingprefs_DATA = \
codec-preferences \
element-properties
+servicefiledir = `pkg-config --variable=session_bus_services_dir dbus-1`
+servicefile_in_files = org.freedesktop.Telepathy.Client.Empathy.service.in
+servicefile_DATA = $(servicefile_in_files:.service.in=.service)
+
+org.freedesktop.Telepathy.Client.Empathy.service: org.freedesktop.Telepathy.Client.Empathy.service.in
+ $(QUIET_GEN)sed -e "s|[@]bindir[@]|$(bindir)|" $< > $@
+
+clientfiledir = $(datarootdir)/telepathy/clients
+clientfile_DATA = Empathy.client
+
if GCONF_SCHEMAS_INSTALL
install-data-local:
if test -z "$(DESTDIR)" ; then \
@@ -35,7 +45,9 @@ EXTRA_DIST = \
$(schemas_in_files) \
$(schemas_DATA) \
$(streamingprefs_DATA) \
- $(html_DATA)
+ $(html_DATA) \
+ $(clientfile_DATA) \
+ $(servicefile_in_files)
DISTCLEANFILES = \
$(desktop_DATA) \