aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2007-05-08 03:48:22 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-05-08 03:48:22 +0800
commitc7010d43264dafca66ff65540c5d6666f1c66e2a (patch)
treeb9913e0042b112a9e97eeb7b00521459a568b58c /data/Makefile.am
parent6e542b100fd2efcfb7b8a3b58bf173fed1e3e494 (diff)
downloadgsoc2013-empathy-c7010d43264dafca66ff65540c5d6666f1c66e2a.tar
gsoc2013-empathy-c7010d43264dafca66ff65540c5d6666f1c66e2a.tar.gz
gsoc2013-empathy-c7010d43264dafca66ff65540c5d6666f1c66e2a.tar.bz2
gsoc2013-empathy-c7010d43264dafca66ff65540c5d6666f1c66e2a.tar.lz
gsoc2013-empathy-c7010d43264dafca66ff65540c5d6666f1c66e2a.tar.xz
gsoc2013-empathy-c7010d43264dafca66ff65540c5d6666f1c66e2a.tar.zst
gsoc2013-empathy-c7010d43264dafca66ff65540c5d6666f1c66e2a.zip
[darcs-to-svn @ Use icon-name API instead of stock icons and update tango icons]
svn path=/trunk/; revision=32
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
new file mode 100644
index 000000000..0f2e1b074
--- /dev/null
+++ b/data/Makefile.am
@@ -0,0 +1,27 @@
+SUBDIRS = 16x16
+
+profiledir = $(datadir)/mission-control/profiles
+profile_DATA = \
+ jabber.profile \
+ gtalk.profile \
+ salut.profile \
+ msn.profile
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+EXTRA_DIST = \
+ $(image_DATA) \
+ $(profile_DATA)
+
+