aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-05-18 21:06:22 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-05-18 22:08:37 +0800
commit326c3a23e79880381917fad9d30de2a4df1c78a8 (patch)
treeffa7292cad95dc88253c003cf71d82f7c8e116b2 /configure.ac
parent70e90db86acce48b34391a5115df23042bd780b6 (diff)
downloadgsoc2013-empathy-326c3a23e79880381917fad9d30de2a4df1c78a8.tar
gsoc2013-empathy-326c3a23e79880381917fad9d30de2a4df1c78a8.tar.gz
gsoc2013-empathy-326c3a23e79880381917fad9d30de2a4df1c78a8.tar.bz2
gsoc2013-empathy-326c3a23e79880381917fad9d30de2a4df1c78a8.tar.lz
gsoc2013-empathy-326c3a23e79880381917fad9d30de2a4df1c78a8.tar.xz
gsoc2013-empathy-326c3a23e79880381917fad9d30de2a4df1c78a8.tar.zst
gsoc2013-empathy-326c3a23e79880381917fad9d30de2a4df1c78a8.zip
enable coding style checks by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 48e41bb5a..195589190 100644
--- a/configure.ac
+++ b/configure.ac
@@ -302,6 +302,15 @@ fi
AM_CONDITIONAL(HAVE_PYTHON, test "x$have_python" = "xyes")
# -----------------------------------------------------------
+# Coding style checks
+# -----------------------------------------------------------
+AC_ARG_ENABLE(coding-style-checks,
+ AC_HELP_STRING([--disable-coding-style-checks],
+ [don't check coding style using grep]),
+ [ENABLE_CODING_STYLE_CHECKS=$enableval], [ENABLE_CODING_STYLE_CHECKS=yes])
+
+AC_SUBST([ENABLE_CODING_STYLE_CHECKS])
+# -----------------------------------------------------------
SHAVE_INIT(.)