aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2010-05-26 18:08:01 +0800
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2010-05-26 18:08:01 +0800
commit961f968f204547c34ad419786447d1904783497f (patch)
tree0560f70b4f6b7ceb982499c81837fe71088eef4a /configure.ac
parent4ba1a8de87f108ad073e388711c4d6b05009851e (diff)
downloadgsoc2013-empathy-961f968f204547c34ad419786447d1904783497f.tar
gsoc2013-empathy-961f968f204547c34ad419786447d1904783497f.tar.gz
gsoc2013-empathy-961f968f204547c34ad419786447d1904783497f.tar.bz2
gsoc2013-empathy-961f968f204547c34ad419786447d1904783497f.tar.lz
gsoc2013-empathy-961f968f204547c34ad419786447d1904783497f.tar.xz
gsoc2013-empathy-961f968f204547c34ad419786447d1904783497f.tar.zst
gsoc2013-empathy-961f968f204547c34ad419786447d1904783497f.zip
configure.ac: improve portability of test(1) calls
The "==" operator isn't POSIX (use "="), and the -a and -o connectors aren't POSIX (use test foo && test bar, test foo || test bar).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5b8de9145..35afac4d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -465,7 +465,7 @@ AC_ARG_ENABLE(favourite_contacts,
[Enable favourite contacts]), ,
enable_favourite_contacts=no)
-if test "x$enable_favourite_contacts" != "xno" -o "x$chain_enable_favourite_contacts" == "xyes"; then
+if test "x$enable_favourite_contacts" != "xno" || test "x$chain_enable_favourite_contacts" = "xyes"; then
PKG_CHECK_MODULES(TELEPATHY_LOGGER,
[
telepathy-logger
@@ -479,7 +479,7 @@ else
have_favourite_contacts="no"
fi
-if test "x$enable_favourite_contacts" = "xyes" -a "x$have_favourite_contacts" != "xyes"; then
+if test "x$enable_favourite_contacts" = "xyes" && test "x$have_favourite_contacts" != "xyes"; then
AC_MSG_ERROR([Couldn't find favourite contacts dependencies.])
fi