aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2010-02-26 16:49:16 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2010-02-26 16:49:16 +0800
commit04a3f49597c3ffb367b48fe6c01f972bdd15ea11 (patch)
tree71365ef368afa72968af8bff1b41d8c0665d1009 /configure.ac
parente86aa1065dbf60d7a1e68bf50d9fbbccbb34312a (diff)
parent28244a9c41e2c4274d2cb298c20b5e8909f7578a (diff)
downloadgsoc2013-empathy-04a3f49597c3ffb367b48fe6c01f972bdd15ea11.tar
gsoc2013-empathy-04a3f49597c3ffb367b48fe6c01f972bdd15ea11.tar.gz
gsoc2013-empathy-04a3f49597c3ffb367b48fe6c01f972bdd15ea11.tar.bz2
gsoc2013-empathy-04a3f49597c3ffb367b48fe6c01f972bdd15ea11.tar.lz
gsoc2013-empathy-04a3f49597c3ffb367b48fe6c01f972bdd15ea11.tar.xz
gsoc2013-empathy-04a3f49597c3ffb367b48fe6c01f972bdd15ea11.tar.zst
gsoc2013-empathy-04a3f49597c3ffb367b48fe6c01f972bdd15ea11.zip
Merge commit 'ka/empathy-tpl-20100225-ifdef'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aabb7fe4d..abb05a4a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,7 @@ GLIB_REQUIRED=2.22.0
GTK_REQUIRED=2.18.0
GCONF_REQUIRED=1.2.0
TELEPATHY_GLIB_REQUIRED=0.9.2
+TELEPATHY_LOGGER=0.1.0
ENCHANT_REQUIRED=1.2.0
ISO_CODES_REQUIRED=0.35
LIBNOTIFY_REQUIRED=0.4.4
@@ -135,6 +136,30 @@ AS_COMPILER_FLAG(-Wmissing-declarations, ERROR_CFLAGS="$ERROR_CFLAGS -Wmissing-d
AC_SUBST(ERROR_CFLAGS)
# -----------------------------------------------------------
+# Enable TPL
+# -----------------------------------------------------------
+
+# It needs to be defined before PKG_CHECK_MODULES calls
+AC_ARG_ENABLE(tpl,
+ AC_HELP_STRING([--enable-tpl],[enable telepathy-logger code and disable the
+ empathy logger]), enable_tpl=$enableval, enable_tpl=no )
+AM_CONDITIONAL(ENABLE_TPL, test "x$enable_tpl" = "xyes")
+
+if test x${enable_tpl} = xyes; then
+ AC_DEFINE(ENABLE_TPL, [], [Enable TPL code])
+fi
+
+if test "x$enable_tpl" = "xyes"; then
+ PKG_CHECK_MODULES(TPL,
+ [
+ libtelepathy-logger = $TELEPATHY_LOGGER
+ ])
+ AC_SUBST(TPL_CFLAGS)
+ AC_SUBST(TPL_LIBS)
+fi
+
+
+# -----------------------------------------------------------
# Pkg-Config dependency checks
# -----------------------------------------------------------
@@ -528,6 +553,9 @@ Configure summary:
Meego widgets ..............: ${have_meego}
Control center embedding....: ${have_control_center_embedding}
+ Logging:
+ Telepathy Logger............: ${enable_tpl}
+
Connectivity:
NetworkManager integration..: ${have_nm}
ConnMan integration.........: ${have_connman}