aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSjoerd Simons <sjoerd.simons@collabora.co.uk>2011-02-24 02:29:30 +0800
committerSjoerd Simons <sjoerd.simons@collabora.co.uk>2011-02-24 02:29:30 +0800
commit857b27e6161b5a010d61a88d0a7ebce6904db49f (patch)
tree0189e9a76fad94a59e12e5fc95de72f84be749c1 /configure.ac
parent0b12f2094066c4697b5eb151f30a186772b8447a (diff)
downloadgsoc2013-empathy-857b27e6161b5a010d61a88d0a7ebce6904db49f.tar
gsoc2013-empathy-857b27e6161b5a010d61a88d0a7ebce6904db49f.tar.gz
gsoc2013-empathy-857b27e6161b5a010d61a88d0a7ebce6904db49f.tar.bz2
gsoc2013-empathy-857b27e6161b5a010d61a88d0a7ebce6904db49f.tar.lz
gsoc2013-empathy-857b27e6161b5a010d61a88d0a7ebce6904db49f.tar.xz
gsoc2013-empathy-857b27e6161b5a010d61a88d0a7ebce6904db49f.tar.zst
gsoc2013-empathy-857b27e6161b5a010d61a88d0a7ebce6904db49f.zip
auto-detect the presence of farsight
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e46dac47e..cf1013191 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,14 +176,24 @@ PKG_CHECK_MODULES(EMPATHY_AV,
AC_ARG_WITH(call,
AC_HELP_STRING([--with-call], [build with Call interface support]),,
[with_call=yes])
-if test "x$with_call" = "xyes" ; then
+if test "x$with_call" != "xno" ; then
PKG_CHECK_MODULES(EMPATHY_CALL,
[
farsight2-0.10
telepathy-farstream
- ])
+ ], have_farstream="yes", have_farstream="no" )
+
+ if test "x$have_farstream" = "xyes"; then
+ AC_DEFINE(HAVE_CALL, 1, [Define if you have Call channel support])
+ fi
+else
+ have_farstream=no
+fi
+
+if test "x$with_call" = "xyes" -a "x$have_farstream" != "xyes"; then
+ AC_MSG_ERROR([Could not find Call handler dependencies.])
fi
-AM_CONDITIONAL(HAVE_CALL, test "x$with_call" = "xyes")
+AM_CONDITIONAL(HAVE_CALL, test "x$have_farstream" = "xyes")
# -----------------------------------------------------------
# evolution-data-server (about-me)
@@ -583,4 +593,5 @@ Configure summary:
Extras:
Nautilus-sendto plugin......: ${have_nst}
Salut E-D-S support.........: ${with_eds}
+ Exp. Call channel handler...: ${have_farstream}
"