aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2009-09-23 21:17:57 +0800
committerBastien Nocera <hadess@hadess.net>2009-09-24 22:09:42 +0800
commit0cd0ad2142e6722ffc620824e424277e1f622ce1 (patch)
tree1d40c390ba44282ab97317bb57e6ea46c43a3fb1 /configure.ac
parent3b1dc603c5f7174904bc1c6c01566700f0bab894 (diff)
downloadgsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar.gz
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar.bz2
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar.lz
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar.xz
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.tar.zst
gsoc2013-empathy-0cd0ad2142e6722ffc620824e424277e1f622ce1.zip
Add nautilus-sendto plugin
As nautilus-sendto now exports its plugin API. https://bugzilla.gnome.org/show_bug.cgi?id=596075
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 826fec3ad..79fc93f89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,6 +41,7 @@ GEOCLUE_REQUIRED=0.11
WEBKIT_REQUIRED=1.1.7
KEYRING_REQUIRED=2.22
NETWORK_MANAGER_REQUIRED=0.7.0
+NAUTILUS_SENDTO_REQUIRED=2.28.0.1
# Use --enable-maintainer-mode to disabled deprecated symbols
GNOME_MAINTAINER_MODE_DEFINES
@@ -353,6 +354,29 @@ fi
AM_CONDITIONAL(HAVE_MEGAPHONE, test "x$have_megaphone" = "xyes")
# -----------------------------------------------------------
+# nautilus-sendto
+# -----------------------------------------------------------
+AC_ARG_ENABLE(nautilus-sendto,
+ AS_HELP_STRING([--enable-nautilus-sendto=@<:@no/yes/auto@:>@],
+ [build nautilus-sendto plugin]), ,
+ enable_nst=auto)
+
+if test "x$enable_nst" != "xno"; then
+ PKG_CHECK_MODULES(NST,
+ [
+ nautilus-sendto >= $NAUTILUS_SENDTO_REQUIRED
+ ], have_nst="yes", have_nst="no")
+else
+ have_nst=no
+fi
+
+if test "x$enable_nst" = "xyes" -a "x$have_nst" != "xyes"; then
+ AC_MSG_ERROR([Couldn't find nautilus-sendto dependencies.])
+fi
+
+AM_CONDITIONAL(HAVE_NST, test "x$have_nst" = "xyes")
+
+# -----------------------------------------------------------
# Nothere
# -----------------------------------------------------------
AC_ARG_ENABLE(nothere,
@@ -465,6 +489,7 @@ AC_OUTPUT([
megaphone/Makefile
megaphone/src/Makefile
megaphone/data/Makefile
+ nautilus-sendto-plugin/Makefile
nothere/Makefile
nothere/src/Makefile
nothere/data/Makefile
@@ -509,4 +534,5 @@ Configure summary:
Python bindings.............: ${have_python}
Megaphone applet............: ${have_megaphone}
Nothere applet..............: ${have_nothere}
+ Nautilus-sendto plugin......: ${have_nst}
"