aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Pepple <bpepple@fedoraproject.org>2010-11-07 06:31:32 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2010-11-18 22:46:43 +0800
commit48289f99b2d22956f87157250d4f40c719412a27 (patch)
treedfd17dadf878fc5e1283aa54a8c593c91dc5fae0 /configure.ac
parent4034e5e3ddd88ec577387766548ca0454cdf6e1a (diff)
downloadgsoc2013-empathy-48289f99b2d22956f87157250d4f40c719412a27.tar
gsoc2013-empathy-48289f99b2d22956f87157250d4f40c719412a27.tar.gz
gsoc2013-empathy-48289f99b2d22956f87157250d4f40c719412a27.tar.bz2
gsoc2013-empathy-48289f99b2d22956f87157250d4f40c719412a27.tar.lz
gsoc2013-empathy-48289f99b2d22956f87157250d4f40c719412a27.tar.xz
gsoc2013-empathy-48289f99b2d22956f87157250d4f40c719412a27.tar.zst
gsoc2013-empathy-48289f99b2d22956f87157250d4f40c719412a27.zip
Make ca-certs location configurable (#634197)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0bef45a27..1b76c0f7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -214,6 +214,38 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[Gettext package name])
AM_GLIB_GNU_GETTEXT
# -----------------------------------------------------------
+# Make CA certificates path configurable
+# Stolen from GIO's TLS
+# -----------------------------------------------------------
+AC_MSG_CHECKING([location of system Certificate Authority list])
+AC_ARG_WITH(ca-file,
+ [AC_HELP_STRING([--with-ca-file=@<:@path@:>@],
+ [path to system Certificate Authority list])])
+if test "$with_ca_file" = "no"; then
+ AC_MSG_RESULT([disabled])
+else
+ if test -z "$with_ca_file"; then
+ for f in /etc/pki/tls/certs/ca-bundle.crt \
+ /etc/ssl/certs/ca-certificates.crt; do
+ if test -f "$f"; then
+ with_ca_file="$f"
+ fi
+ done
+ if test -z "$with_ca_file"; then
+ AC_MSG_ERROR([could not find. Use --with-ca-file=path to set, or --without-ca-file to disable])
+ fi
+ fi
+
+ AC_MSG_RESULT($with_ca_file)
+ if ! test -f "$with_ca_file"; then
+ AC_MSG_ERROR([No such file '$with_ca_file'. Use --with-ca-file=path to set, or --without-ca-file to disable])
+ fi
+ GTLS_SYSTEM_CA_FILE="$with_ca_file"
+
+ AC_DEFINE_UNQUOTED([GTLS_SYSTEM_CA_FILE], ["$GTLS_SYSTEM_CA_FILE"], [path to system Certificate Authority list])
+fi
+
+# -----------------------------------------------------------
# Connectivity integration
# -----------------------------------------------------------
AC_ARG_WITH(connectivity,
@@ -511,6 +543,7 @@ Configure summary:
Compiler Flags..............: ${CFLAGS} ${ERROR_CFLAGS}
Prefix......................: ${prefix}
Coding style checks.........: ${ENABLE_CODING_STYLE_CHECKS}
+ CA Cert Path................: ${GTLS_SYSTEM_CA_FILE}
Features:
Spell checking (enchant)....: ${have_enchant}