aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2008-04-22 18:18:11 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2008-04-22 18:18:11 +0800
commitbeecbb7de2abf1ba7eed3cfc46e4a1b150e433bb (patch)
tree5ffdb234e3a43967bc6d0ce6de48a6fb384376b7 /configure.ac
parentd8af806a5349ed9a64838c250ff8ff7c8de2e118 (diff)
downloadgsoc2013-empathy-beecbb7de2abf1ba7eed3cfc46e4a1b150e433bb.tar
gsoc2013-empathy-beecbb7de2abf1ba7eed3cfc46e4a1b150e433bb.tar.gz
gsoc2013-empathy-beecbb7de2abf1ba7eed3cfc46e4a1b150e433bb.tar.bz2
gsoc2013-empathy-beecbb7de2abf1ba7eed3cfc46e4a1b150e433bb.tar.lz
gsoc2013-empathy-beecbb7de2abf1ba7eed3cfc46e4a1b150e433bb.tar.xz
gsoc2013-empathy-beecbb7de2abf1ba7eed3cfc46e4a1b150e433bb.tar.zst
gsoc2013-empathy-beecbb7de2abf1ba7eed3cfc46e4a1b150e433bb.zip
Cleanup the spell code.
svn path=/trunk/; revision=1031
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac86
1 files changed, 34 insertions, 52 deletions
diff --git a/configure.ac b/configure.ac
index 374756a56..f307ffe02 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,8 @@ LIBGLADE_REQUIRED=2.0.0
LIBPANELAPPLET_REQUIRED=2.10.0
TELEPATHY_GLIB_REQUIRED=0.7.3
MISSION_CONTROL_REQUIRED=4.61
+ENCHANT_REQUIRED=1.2.0
+ISO_CODES_REQUIRED=0.35
# Uncomment that to build without deprecated symbols
# AC_DEFINE(GTK_DISABLE_DEPRECATED, 1, [Disable deprecated GTK symbols])
@@ -111,63 +113,43 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[Gettext package name])
AM_GLIB_GNU_GETTEXT
-dnl ================================================================
-dnl spellchecking checks: enchant and iso-codes
-dnl ================================================================
-
-ENCHANT_REQUIRED=1.2.0
-ISO_CODES_REQUIRED=0.35
+# -----------------------------------------------------------
+# spellchecking checks: enchant and iso-codes
+# -----------------------------------------------------------
+AC_ARG_ENABLE(spell,
+ AS_HELP_STRING([--enable-spell=@<:@no/yes/auto@:>@],
+ [Enable spell checking]), ,
+ enable_spell=auto)
-AC_ARG_ENABLE([spell],
- AS_HELP_STRING([--disable-spell],[Disable spell checking (default: enabled)]),
- [enable_enchant=$enableval],
- [enable_enchant=yes])
-
-if test "x$enable_enchant" = "xyes" ; then
-
- PKG_CHECK_MODULES(ENCHANT, enchant >= $ENCHANT_REQUIRED, \
- have_enchant=yes, have_enchant=no)
-
- if test "x$have_enchant" = "xyes"; then
-
- PKG_CHECK_EXISTS([iso-codes >= $ISO_CODES_REQUIRED],
- [have_iso_codes=yes],[have_iso_codes=no])
-
- if test "x$have_iso_codes" = "xyes"; then
- AC_MSG_CHECKING([whether iso-codes has iso-639 and iso-3166 domains])
- if $PKG_CONFIG --variable=domains iso-codes | grep 639 > /dev/null && \
- $PKG_CONFIG --variable=domains iso-codes | grep 3166 > /dev/null ; then
- result=yes
- else
- result=no
- have_iso_codes=no
- fi
- AC_MSG_RESULT([$result])
- fi
-
- if test "x$have_iso_codes" = "xyes"; then
- AC_DEFINE_UNQUOTED([ISO_CODES_PREFIX],["`$PKG_CONFIG --variable=prefix iso-codes`"],[ISO codes prefix])
- AC_DEFINE([HAVE_ISO_CODES],[1],[Define if you have the iso-codes package])
- else
- AC_MSG_ERROR([iso-codes is required for spellchecking. Use --disable-spell to build without spellchecking support.])
- fi
-
- enable_enchant=yes
- ENCHANT_CFLAGS="${ENCHANT_CFLAGS}"
- ENCHANT_LIBS="${ENCHANT_LIBS}"
- AC_DEFINE([HAVE_ENCHANT],[1],[Define if you have libenchant])
- else
- AC_MSG_ERROR([Enchant library not found or too old. Use --disable-spell to build without spellchecking support.])
- fi
+if test "x$enable_spell" != "xno"; then
+ PKG_CHECK_MODULES(ENCHANT,
+ [
+ enchant >= $ENCHANT_REQUIRED,
+ iso-codes >= $ISO_CODES_REQUIRED
+ ], have_enchant="yes", have_enchant="no")
+
+ if test "x$have_enchant" = "xyes"; then
+ AC_MSG_CHECKING([whether iso-codes has iso-639 and iso-3166 domains])
+ if $PKG_CONFIG --variable=domains iso-codes | grep 639 > /dev/null && \
+ $PKG_CONFIG --variable=domains iso-codes | grep 3166 > /dev/null ; then
+ AC_DEFINE_UNQUOTED(ISO_CODES_PREFIX, ["`$PKG_CONFIG --variable=prefix iso-codes`"], [ISO codes prefix])
+ AC_DEFINE(HAVE_ENCHANT, 1, [Define if you have libenchant])
+ result=yes
+ else
+ result=no
+ have_enchant="no"
+ fi
+ AC_MSG_RESULT([$result])
+ fi
else
- enable_enchant=no
- ENCHANT_CFLAGS=
- ENCHANT_LIBS=
+ have_enchant=no
fi
-AC_SUBST(ENCHANT_CFLAGS)
-AC_SUBST(ENCHANT_LIBS)
+if test "x$enable_spell" = "xyes" -a "x$have_enchant" != "xyes"; then
+ AC_MSG_ERROR([Couldn't find spell dependencies.])
+fi
+AM_CONDITIONAL(HAVE_ENCHANT, test "x$have_enchant" = "xyes")
# -----------------------------------------------------------
# Megaphone