aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-07-17 23:24:51 +0800
committerXavier Claessens <xavier.claessens@collabora.co.uk>2012-07-23 20:34:17 +0800
commitbd30ca4a72d7a44655df45cc2384280e63ada502 (patch)
tree495a85ff44412231553c70ac73c15845ea904d62 /configure.ac
parentfb37d92e195871b3e5a485d513bf6a7618a8eb60 (diff)
downloadgsoc2013-empathy-bd30ca4a72d7a44655df45cc2384280e63ada502.tar
gsoc2013-empathy-bd30ca4a72d7a44655df45cc2384280e63ada502.tar.gz
gsoc2013-empathy-bd30ca4a72d7a44655df45cc2384280e63ada502.tar.bz2
gsoc2013-empathy-bd30ca4a72d7a44655df45cc2384280e63ada502.tar.lz
gsoc2013-empathy-bd30ca4a72d7a44655df45cc2384280e63ada502.tar.xz
gsoc2013-empathy-bd30ca4a72d7a44655df45cc2384280e63ada502.tar.zst
gsoc2013-empathy-bd30ca4a72d7a44655df45cc2384280e63ada502.zip
configure.ac: export a bunch of variables from UOA pc files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f4518ef46..73ad611dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -514,6 +514,27 @@ if test "x$enable_ubuntu_online_accounts" != "xno"; then
mission-control-plugins
libaccounts-glib >= $LIBACCOUNTS_REQUIRED
], have_uoa="yes", have_uoa="no")
+
+ # provider plugin dir
+ AC_MSG_CHECKING([Accounts provider plugin dir])
+ ACCOUNTS_PROVIDER_PLUGIN_DIR=`pkg-config --variable=provider_plugindir account-plugin`
+
+ AC_MSG_RESULT([$ACCOUNTS_PROVIDER_PLUGIN_DIR])
+ AC_SUBST(ACCOUNTS_PROVIDER_PLUGIN_DIR)
+
+ # provider files dir
+ AC_MSG_CHECKING([Accounts provider files dir])
+ ACCOUNTS_PROVIDER_FILES_DIR=`pkg-config --variable=providerfilesdir libaccounts-glib`
+
+ AC_MSG_RESULT([$ACCOUNTS_PROVIDER_FILES_DIR])
+ AC_SUBST(ACCOUNTS_PROVIDER_FILES_DIR)
+
+ # service files dir
+ AC_MSG_CHECKING([Accounts service files dir])
+ ACCOUNTS_SERVICE_FILES_DIR=`pkg-config --variable=servicefilesdir libaccounts-glib`
+
+ AC_MSG_RESULT([$ACCOUNTS_SERVICE_FILES_DIR])
+ AC_SUBST(ACCOUNTS_SERVICE_FILES_DIR)
else
have_uoa=no
fi