aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-02-24 00:19:48 +0800
committerEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-06-09 17:20:05 +0800
commit36581b216476e337425ca8737aa7059062a81d99 (patch)
treefcfb67cc5f92cb0652ad625e6a226c30480ee8e5 /configure.ac
parenta5e92745d265b5623c045b6cc90164af89b25ded (diff)
downloadgsoc2013-empathy-36581b216476e337425ca8737aa7059062a81d99.tar
gsoc2013-empathy-36581b216476e337425ca8737aa7059062a81d99.tar.gz
gsoc2013-empathy-36581b216476e337425ca8737aa7059062a81d99.tar.bz2
gsoc2013-empathy-36581b216476e337425ca8737aa7059062a81d99.tar.lz
gsoc2013-empathy-36581b216476e337425ca8737aa7059062a81d99.tar.xz
gsoc2013-empathy-36581b216476e337425ca8737aa7059062a81d99.tar.zst
gsoc2013-empathy-36581b216476e337425ca8737aa7059062a81d99.zip
Always build telepathy-yell and handle Call channels
Just keep empathy-call optional. Conflicts: libempathy-gtk/empathy-call-utils.c libempathy/empathy-channel-factory.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3d0437532..1c87649bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,6 +172,8 @@ PKG_CHECK_MODULES(EMPATHY,
gcr-3 >= $GCR_REQUIRED
])
+PKG_CHECK_MODULES(YELL, [telepathy-yell])
+
PKG_CHECK_MODULES(EMPATHY_AV,
[
farsight2-0.10
@@ -185,13 +187,11 @@ AC_ARG_WITH(call,
AC_HELP_STRING([--with-call], [build with Call interface support]),,
[with_call=yes])
if test "x$with_call" = "xyes" ; then
- PKG_CHECK_MODULES(YELL, [telepathy-yell])
PKG_CHECK_MODULES(EMPATHY_CALL,
[
farsight2-0.10
telepathy-farstream
])
- AC_DEFINE(HAVE_CALL, 1, [Define if we have Call interface support])
fi
AM_CONDITIONAL(HAVE_CALL, test "x$with_call" = "xyes")