aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlban Crequy <alban.crequy@collabora.co.uk>2011-08-22 23:57:52 +0800
committerAlban Crequy <alban.crequy@collabora.co.uk>2011-08-23 20:40:34 +0800
commitec1594416d7fc29c7baeeb10f7645934a9679bb5 (patch)
tree64e186e70a1a365d7cebf3b5bf0a09aa5e8bec6a /configure.ac
parent20a005394616e171ab3c7a974122bfa01df426a2 (diff)
downloadgsoc2013-empathy-ec1594416d7fc29c7baeeb10f7645934a9679bb5.tar
gsoc2013-empathy-ec1594416d7fc29c7baeeb10f7645934a9679bb5.tar.gz
gsoc2013-empathy-ec1594416d7fc29c7baeeb10f7645934a9679bb5.tar.bz2
gsoc2013-empathy-ec1594416d7fc29c7baeeb10f7645934a9679bb5.tar.lz
gsoc2013-empathy-ec1594416d7fc29c7baeeb10f7645934a9679bb5.tar.xz
gsoc2013-empathy-ec1594416d7fc29c7baeeb10f7645934a9679bb5.tar.zst
gsoc2013-empathy-ec1594416d7fc29c7baeeb10f7645934a9679bb5.zip
Add a configure option for GProf
It should help to investigate https://bugzilla.gnome.org/show_bug.cgi?id=657086
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 977319090..cb60cf5f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,17 @@ AS_COMPILER_FLAG(-Wstrict-prototypes, ERROR_CFLAGS="$ERROR_CFLAGS -Wstrict-proto
AC_SUBST(ERROR_CFLAGS)
+AC_ARG_ENABLE(gprof,
+ AS_HELP_STRING([--enable-gprof=@<:@no/yes@:>@],
+ [build with support for gprof]),,
+ [enable_gprof=no])
+if test "x$enable_gprof" != "xno" ; then
+ CFLAGS="$CFLAGS -pg"
+ LDFLAGS="$LDFLAGS -pg"
+fi
+
+AC_SUBST(LDFLAGS)
+
# -----------------------------------------------------------
# Pkg-Config dependency checks
# -----------------------------------------------------------
@@ -639,6 +650,7 @@ Configure summary:
Compiler....................: ${CC}
Compiler Flags..............: ${CFLAGS} ${ERROR_CFLAGS}
+ Linker Flags................: ${LDFLAGS}
Prefix......................: ${prefix}
Coding style checks.........: ${ENABLE_CODING_STYLE_CHECKS}